summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormodula t. worm2019-03-27 05:32:11 -0500
committermodula t. worm2019-03-27 05:32:11 -0500
commit5b4af12da43bc15b5275e6515297bdacb1aee4b4 (patch)
tree842fa5bb7fd9d32f144704c40d72a81fd83a0da8
parent6906f58dffe308e671a0bea3a08df7c19c6ce6d9 (diff)
downloadaur-5b4af12da43bc15b5275e6515297bdacb1aee4b4.tar.gz
fix apparently-problematic lines in newt_lv2_instr.ttl + indentation
-rw-r--r--PKGBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2c221c294098..074a319489f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=newtonator
pkgver=0.6.0
-pkgrel=1
+pkgrel=2
pkgdesc="An LV2 soft synth based on velocity and acceleration"
arch=(i686 x86_64)
url="http://newtonator.sourceforge.net/"
@@ -15,19 +15,22 @@ source=("http://downloads.sourceforge.net/project/$pkgname/$pkgname-$pkgver.tar.
md5sums=('7f2db9a8928c5e06af1312f50c806646')
prepare() {
- cd $pkgname-$pkgver
- [ -d b ] || mkdir b
+ cd $pkgname-$pkgver
+ [ -d b ] || mkdir b
}
build() {
- cd $pkgname-$pkgver/b
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cd $pkgname-$pkgver/b
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ make
+
+ # comment out apparently problematic lines in newt_lv2_instr.ttl
+ sed -i 's/foaf/#foaf/g' ../src/newt_lv2_instr/bundle/newt_lv2_instr.ttl
}
package() {
- cd $pkgname-$pkgver/b
- make DESTDIR="$pkgdir/" install
+ cd $pkgname-$pkgver/b
+ make DESTDIR="$pkgdir/" install
}
# vim:set ts=2 sw=2 et: