summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Puls2019-12-09 04:41:09 +0100
committerAlexander Puls2019-12-09 04:41:09 +0100
commit5b5319449c99270e9dc1977c294ed7ddda5cd1f9 (patch)
tree7670ff799460700ccc1a400ec095c39d24f8e584
downloadaur-5b5319449c99270e9dc1977c294ed7ddda5cd1f9.tar.gz
initial PKGBUILD
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD31
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c8bb1ffb16de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = clweather
+ pkgdesc = small weather forecast script for the command line
+ pkgver = 1.2.r4.g5710eb0
+ pkgrel = 1
+ url = https://gitlab.com/0vv1/clweather
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = sed
+ depends = python
+ depends = python-argparse
+ depends = python-requests
+ optdepends = nerd-fonts-ANY: to get the Unicode symbols of Weather Icons OR
+ optdepends = ttf-nerd-fonts-ANY: to get correct Unicode symbols OR
+ optdepends = otf-nerd-fonts-ANY: to get correct Unicode symbols
+ provides = clweather
+ conflicts = clweather
+ source = git+https://gitlab.com/0vv1/clweather.git
+ md5sums = SKIP
+
+pkgname = clweather
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c38548655770
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Alexander Puls <x.com [at] mailbox.org>
+# Contributor: Alexander Puls <x.com [at] mailbox.org>
+
+pkgname=clweather
+_pkgname=clweather.py
+pkgver=1.2.r4.g5710eb0
+pkgrel=1
+pkgdesc="small weather forecast script for the command line"
+arch=('any')
+url='https://gitlab.com/0vv1/clweather'
+license=('GPL3')
+groups=()
+depends=('python' 'python-argparse' 'python-requests')
+optdepends=('nerd-fonts-ANY: to get the Unicode symbols of Weather Icons OR'
+ 'ttf-nerd-fonts-ANY: to get correct Unicode symbols OR'
+ 'otf-nerd-fonts-ANY: to get correct Unicode symbols')
+makedepends=('git' 'sed')
+provides=($pkgname)
+conflicts=($pkgname)
+source=("git+https://gitlab.com/0vv1/clweather.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd $pkgname
+ install -Dm755 $_pkgname "$pkgdir/usr/bin/$pkgname"
+}