summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederick Hornsey2020-11-23 02:22:17 -0600
committerFrederick Hornsey2020-11-23 02:22:17 -0600
commit5b5bad1fe8b1e780da1c342430c7efa1f59fe727 (patch)
tree7a8995ed245c97f761f67f8019d064bac25a6ca8
parent7430ca6640de196cc994281e885c67c909c2ffd2 (diff)
downloadaur-5b5bad1fe8b1e780da1c342430c7efa1f59fe727.tar.gz
Update to OpenDDS 3.14.1, ACE/TAO 6.5.12
Also add script to strip $srcdir from generated files so makepkg stops complaining about them. It still will complain about binary files for now.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
-rw-r--r--strip.pl26
3 files changed, 45 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 562d9d597426..8301a4f0061e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = opendds
pkgdesc = Open source C++ implementation of OMG Data Distribution Service (DDS)
- pkgver = 3.14.0
- pkgrel = 2
+ pkgver = 3.14.1
+ pkgrel = 1
url = http://www.opendds.org/
arch = i686
arch = x86_64
@@ -11,11 +11,11 @@ pkgbase = opendds
provides = ace
provides = tao
options = !buildflags
- source = https://github.com/DOCGroup/ACE_TAO/releases/download/ACE%2BTAO-6_5_11/ACE+TAO-6.5.11.tar.gz
- source = https://github.com/objectcomputing/OpenDDS/releases/download/DDS-3.14/OpenDDS-3.14.tar.gz
+ source = https://github.com/DOCGroup/ACE_TAO/releases/download/ACE%2BTAO-6_5_12/ACE+TAO-6.5.12.tar.gz
+ source = https://github.com/objectcomputing/OpenDDS/releases/download/DDS-3.14.1/OpenDDS-3.14.1.tar.gz
source = build.patch
- md5sums = 09f4281db7a398b20dddcbfa787ac04f
- md5sums = 604aca1898673a7ce5af0f72a0fda8cf
+ md5sums = ae54336fbbec7a5d2e197c4b0dc0d5b8
+ md5sums = bfbb96e6cfe1304e60c778fb7a6bc278
md5sums = c44b0c8d7ebccc2b9be0a040ec9f8c2b
pkgname = opendds
diff --git a/PKGBUILD b/PKGBUILD
index a6fc9596a121..08a15741f8e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,10 @@
pkgname=opendds
_pkgname=OpenDDS
-pkgver=3.14.0
-pkgrel=2
+pkgver=3.14.1
+pkgrel=1
_opendds_version=$(echo $pkgver | sed -e 's/\.0$//g')
-_ace_tao_version=6.5.11
+_ace_tao_version=6.5.12
pkgdesc="Open source C++ implementation of OMG Data Distribution Service (DDS)"
arch=('i686' 'x86_64')
url="http://www.opendds.org/"
@@ -21,11 +21,13 @@ source=(
build.patch
)
md5sums=(
- '09f4281db7a398b20dddcbfa787ac04f'
- '604aca1898673a7ce5af0f72a0fda8cf'
+ 'ae54336fbbec7a5d2e197c4b0dc0d5b8'
+ 'bfbb96e6cfe1304e60c778fb7a6bc278'
'c44b0c8d7ebccc2b9be0a040ec9f8c2b'
)
+_strip_pl="$(realpath strip.pl)"
+
prepare() {
cd "$srcdir"
mv "OpenDDS-$_opendds_version" OpenDDS
@@ -39,7 +41,8 @@ build() {
--configh '#define ACE_LACKS_READDIR_R' \
--configh '#define ACE_DISABLE_MKTEMP' \
--configh '#define ACE_DISABLE_TEMPNAM' \
- --no-tests
+ --no-tests \
+ --no-debug
make
}
@@ -51,6 +54,10 @@ package() {
install -Dm644 "$DDS_ROOT/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/OpenDDS_LICENSE"
install -Dm644 ACE_wrappers/COPYING "$pkgdir/usr/share/licenses/$pkgname/ACE_TAO_LICENSE"
# TODO Other licences
+
+ # Strip $srcdir from Generated Files
+ cd "$pkgdir"
+ perl "$_strip_pl" "$srcdir"
}
# vim:set ts=2 sw=2 et:
diff --git a/strip.pl b/strip.pl
new file mode 100644
index 000000000000..548a157f8991
--- /dev/null
+++ b/strip.pl
@@ -0,0 +1,26 @@
+# Strip paths from generated IDL headers that could be installed
+use strict;
+use warnings;
+
+use File::Find qw/find/;
+use Cwd qw/abs_path/;
+
+my $srcdir = abs_path($ARGV[0]);
+my $srcdir_re = quotemeta($srcdir);
+
+sub path_func {
+ my $path = $_;
+ return if (!-T $path);
+ open(my $file, "+<$path") or die("Could not open $path: $!");
+ my $lines = "";
+ while (my $line = <$file>) {
+ $line =~ s/$srcdir_re\/?//g;
+ $lines .= $line;
+ }
+ seek($file, 0, 0);
+ print $file $lines;
+ truncate($file, tell($file));
+ close($file);
+}
+
+find({wanted => \&path_func, follow => 0, no_chdir => 1}, abs_path("."));