summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-11-17 22:41:17 +0300
committerCaleb Maclennan2021-11-17 22:41:17 +0300
commit5b7017019805059990f5b8270a8f7be22de2900b (patch)
tree2d8b8870a879c2b7d988413863fe929b3d80312e
parent497ca0c49a655c07a1f112afd56683b9d85a155e (diff)
downloadaur-5b7017019805059990f5b8270a8f7be22de2900b.tar.gz
upgpkg: gitahead 2.6.3-5
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD17
2 files changed, 8 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 028aa3522889..e5668c1bd49f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = gitahead
pkgdesc = Understand your Git history!
pkgver = 2.6.3
- pkgrel = 4
+ pkgrel = 5
url = https://www.gitahead.com/
arch = x86_64
license = MIT
makedepends = cmake
- makedepends = ninja
makedepends = qt5-tools
makedepends = qt5-translations
depends = desktop-file-utils
diff --git a/PKGBUILD b/PKGBUILD
index fc654d0fbe96..0b0cdae37471 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=gitahead
pkgver=2.6.3
-pkgrel=4
+pkgrel=5
pkgdesc='Understand your Git history!'
url='https://www.gitahead.com/'
arch=(x86_64)
@@ -17,7 +17,6 @@ depends=(desktop-file-utils
org.freedesktop.secrets
qt5-base)
makedepends=(cmake
- ninja
qt5-tools
qt5-translations)
source=("git+https://github.com/$pkgname/$pkgname#tag=v$pkgver"
@@ -34,23 +33,21 @@ prepare() {
}
build() {
- cd "$pkgname"
cmake \
- -G Ninja \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_PREFIX_PATH=/usr/lib \
- -C build
- gitahead
- ninja -C build
+ -B build \
+ -S "$pkgname"
+ cmake --build build
}
package() {
cd "$pkgname"
install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE.md
- install -Dm0644 -t "$pkgdir/usr/share/applications/" "$pkgname.desktop"
- ninja -C build package
+ install -Dm0644 -t "$pkgdir/usr/share/applications/" "../$pkgname.desktop"
+ cmake --build ../build --target package
mkdir -p "$pkgdir/usr/"{share,bin}
- cp -r "$srcdir/build/_CPack_Packages/Linux/STGZ/GitAhead-$pkgver" "$pkgdir/usr/share/gitahead"
+ cp -r "../build/_CPack_Packages/Linux/STGZ/GitAhead-$pkgver" "$pkgdir/usr/share/gitahead"
rm -rf "$pkgdir/usr/share/gitahead/"*.so.*
ln -s "/usr/share/gitahead/GitAhead" "$pkgdir/usr/bin/gitahead"
cd "$pkgdir/usr/share"