summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGitHub Action2021-06-20 02:00:33 +0000
committerGitHub Action2021-06-20 02:00:33 +0000
commit5b8eab640b61acf2ae6f95b26acbf6047b2a3408 (patch)
treed2cb0ee80d3011247e449a29dcdd77bde9569519
parent61c773b802278d8e4897803c95680f27f453f435 (diff)
downloadaur-5b8eab640b61acf2ae6f95b26acbf6047b2a3408.tar.gz
Update from GitHub Actions: nodejs-foundation-cli: update to 2.2.6-1
https://github.com/ouuan/AUR-packages/actions/runs/953559490
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
3 files changed, 18 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4fbd3392995..d2e00657cb1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
-# Generated by mksrcinfo v8
-# Wed Jul 13 10:43:27 UTC 2016
pkgbase = nodejs-foundation-cli
- pkgdesc = Command-line interface for the Foundation family of frameworks.
- pkgver = 2.1.0
+ pkgdesc = The command line installer for Foundation Sites, Emails, Apps.
+ pkgver = 2.2.6
pkgrel = 1
- url = http://foundation.zurb.com/
+ url = https://github.com/foundation/foundation-cli
arch = any
license = MIT
+ makedepends = npm
depends = nodejs
- depends = npm
- noextract = foundation-cli-2.1.0.tgz
- source = https://registry.npmjs.org/foundation-cli/-/foundation-cli-2.1.0.tgz
- sha256sums = eb14342835eca949729eefa1554a509ce9c70d8d035124d2470437b3c929be5a
+ noextract = foundation-cli-2.2.6.tgz
+ source = https://registry.npmjs.org/foundation-cli/-/foundation-cli-2.2.6.tgz
+ sha256sums = d5fe338fb0056fbba4cc8ee50dabff80a040a8ca694a163f17947c4cf9cbf80f
pkgname = nodejs-foundation-cli
-
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index f71c635dafda..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-*
-!.gitignore
-!PKGBUILD
-!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index d933ebd0872e..b1945b4fdde3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,25 @@
-# Maintainer: Mario Finelli <mario at finel dot li>
+# Maintainer: Yufan You <ouuansteve at gmail>
+# Contributor: Mario Finelli <mario at finel dot li>
_npmname=foundation-cli
-pkgname=nodejs-$_npmname
-pkgver=2.1.0
+pkgname=nodejs-foundation-cli
+pkgver=2.2.6
pkgrel=1
-pkgdesc="Command-line interface for the Foundation family of frameworks."
+pkgdesc="The command line installer for Foundation Sites, Emails, Apps."
arch=('any')
-url="http://foundation.zurb.com/"
+url="https://github.com/foundation/foundation-cli"
license=('MIT')
-depends=('nodejs' 'npm')
+depends=('nodejs')
+makedepends=('npm')
source=(https://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz)
noextract=($_npmname-$pkgver.tgz)
-sha256sums=('eb14342835eca949729eefa1554a509ce9c70d8d035124d2470437b3c929be5a')
+sha256sums=('d5fe338fb0056fbba4cc8ee50dabff80a040a8ca694a163f17947c4cf9cbf80f')
package() {
cd "$srcdir"
local _npmdir="$pkgdir/usr/lib/node_modules/"
mkdir -p "$_npmdir"
cd "$_npmdir"
- npm install --user root -g --prefix "$pkgdir/usr" $_npmname@$pkgver
+ npm install -g --prefix "$pkgdir/usr" "$_npmname@$pkgver"
+ chown -R root:root "${pkgdir}"
}