summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-11-28 16:39:15 -0600
committerLuis Martinez2022-11-28 16:39:15 -0600
commit5b8efe6f5c07da8bc975524750258478a047e20f (patch)
tree630302870caef3ec70ce032d5605b4b614ea320b
parentc117b08c2ac817277dc7005c6bb8c72b9064dcd9 (diff)
downloadaur-5b8efe6f5c07da8bc975524750258478a047e20f.tar.gz
update to 3.1.0
-rw-r--r--.SRCINFO22
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD52
3 files changed, 69 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1372e65ade49..47d61f273876 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,18 @@
pkgbase = afancontrol
- pkgdesc = Advanced Fan Control program, which controls PWM fans according to the current temperatures of the system components.
- pkgver = 3.0.0
- pkgrel = 2
+ pkgdesc = Advanced fan control daemon
+ pkgver = 3.1.0
+ pkgrel = 1
url = https://github.com/KostyaEsmukov/afancontrol
arch = any
license = MIT
+ checkdepends = python-pytest
+ checkdepends = python-requests
+ checkdepends = python-pyserial
+ checkdepends = python-prometheus_client
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python-click
optdepends = lm_sensors: to use the motherboard-based sensors and PWM fans
optdepends = freeipmi: readonly PWM fans
@@ -13,7 +20,12 @@ pkgbase = afancontrol
optdepends = python-pyserial: Arduino support
optdepends = python-prometheus_client: Prometheus support
backup = etc/afancontrol/afancontrol.conf
- source = afancontrol-3.0.0.tar.gz::https://github.com/KostyaEsmukov/afancontrol/archive/3.0.0.tar.gz
- sha256sums = 2d954c3e382c1d60d02dae89eec1349bd71440927a8fd582ae67031fdb1c3540
+ source = afancontrol-3.1.0.tar.gz::https://files.pythonhosted.org/packages/source/a/afancontrol/afancontrol-3.1.0.tar.gz
+ source = afancontrol-3.1.0.tar.gz.asc::https://files.pythonhosted.org/packages/source/a/afancontrol/afancontrol-3.1.0.tar.gz.asc
+ source = LICENSE
+ validpgpkeys = A18FE9F6F570D5B4E1E1853FAA7B5406547AF062
+ sha256sums = 1403995a84a2ec880e36d36ca54c51e21e459e492b36b13437ceb5b792c7a46c
+ sha256sums = SKIP
+ sha256sums = cfbf3d258bc1990f8633f0751cf14515500938a6949ff413f6491dfe4b804d1a
pkgname = afancontrol
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..5785e466a1ed
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2019 Kostya Esmukov <kostya@esmukov.ru>
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 8bd07368b7be..d490bd9a9d52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,52 @@
-# Maintainer:
-# Contributor Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Artem Klevtsov <a.a.klevtsov@gmail com>
+
pkgname=afancontrol
-pkgver=3.0.0
-pkgrel=2
-pkgdesc="Advanced Fan Control program, which controls PWM fans according to the current temperatures of the system components."
+pkgver=3.1.0
+pkgrel=1
+pkgdesc="Advanced fan control daemon"
arch=('any')
url="https://github.com/KostyaEsmukov/afancontrol"
license=('MIT')
depends=('python-click')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+checkdepends=('python-pytest' 'python-requests' 'python-pyserial' 'python-prometheus_client')
optdepends=('lm_sensors: to use the motherboard-based sensors and PWM fans'
'freeipmi: readonly PWM fans'
'hddtemp: for measuring HDD/SSD temperatures'
'python-pyserial: Arduino support'
'python-prometheus_client: Prometheus support')
backup=("etc/$pkgname/$pkgname.conf")
-source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('2d954c3e382c1d60d02dae89eec1349bd71440927a8fd582ae67031fdb1c3540')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/a/$pkgname/$pkgname-$pkgver.tar.gz"
+ "$pkgname-$pkgver.tar.gz.asc::https://files.pythonhosted.org/packages/source/a/$pkgname/$pkgname-$pkgver.tar.gz.asc"
+ 'LICENSE')
+sha256sums=('1403995a84a2ec880e36d36ca54c51e21e459e492b36b13437ceb5b792c7a46c'
+ 'SKIP'
+ 'cfbf3d258bc1990f8633f0751cf14515500938a6949ff413f6491dfe4b804d1a')
+validpgpkeys=('A18FE9F6F570D5B4E1E1853FAA7B5406547AF062')
prepare() {
- cd "$pkgname-$pkgver"
- sed -i 's/etc\/systemd/lib\/systemd/g' setup.py
- sed -i 's/usr\/local/usr/g' "pkg/$pkgname.conf"
+ cd "$pkgname-$pkgver"
+ sed -i \
+ -e '/etc\/afancontrol/d' \
+ -e 's|etc/systemd|lib/systemd|g' setup.py
+ sed -i 's|usr/local|usr|g' "pkg/$pkgname.conf"
}
build() {
- cd "$pkgname-$pkgver"
- python setup.py build
+ cd "$pkgname-$pkgver"
+ python -m build --wheel --no-isolation
}
-package() {
- cd "$pkgname-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
-
- install -d "$pkgdir/etc"
- mv "$pkgdir/usr/etc/afancontrol" "$pkgdir/etc"
- rmdir "$pkgdir/usr/etc"
+check() {
+ cd "$pkgname-$pkgver"
+ PYTHONPATH="$PWD/src" pytest -x
+}
- install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+package() {
+ cd "$pkgname-$pkgver"
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dvm644 "$srcdir/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dvm644 "pkg/$pkgname.conf" -t "$pkgdir/etc/$pkgname/"
}