summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrody2024-04-30 09:12:23 +0200
committerBrody2024-04-30 09:12:23 +0200
commit5b9e1744c8dd6f73d5cc0effc58d8a062a2fe528 (patch)
tree226027394fbe710187d3cf12e640a5694898b0af
parent00f5702e0670a39f9a1786ad20c0553771429ebc (diff)
downloadaur-5b9e1744c8dd6f73d5cc0effc58d8a062a2fe528.tar.gz
Update to 0.8.2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f020685027ae..4c72d94eee84 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = oversteer
pkgdesc = Graphical application to configure Logitech Wheels
- pkgver = 0.8.1
- pkgrel = 2
+ pkgver = 0.8.2
+ pkgrel = 1
url = https://github.com/berarma/oversteer
arch = any
license = GPL3
@@ -15,9 +15,9 @@ pkgbase = oversteer
depends = python-gobject
depends = python-matplotlib
depends = python-pyudev
- depends = python-scipy
depends = python-pyxdg
- source = oversteer-0.8.1.tar.gz::https://github.com/berarma/oversteer/archive/0.8.1.tar.gz
- sha256sums = 26479ef8b06da2373d67bbf803fb3e7b12bea37506ad3b9d5a3376b08d225d25
+ depends = python-scipy
+ source = oversteer-0.8.2.tar.gz::https://github.com/berarma/oversteer/archive/v0.8.2.tar.gz
+ b2sums = b282ab666a88042cba259f524a81c2d54ac5c1a62456ddae38f494a979c5e33b4b023ed5a4a89ad12bf4125d99b9c710baf4ae106c5b9acd3f4682b8afdcb422
pkgname = oversteer
diff --git a/PKGBUILD b/PKGBUILD
index 0633a68f5b6c..d7807dee0860 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Darvin Delgado <dnmodder@gmail.com>
pkgname=oversteer
-pkgver=0.8.1
-pkgrel=2
+pkgver=0.8.2
+pkgrel=1
pkgdesc='Graphical application to configure Logitech Wheels'
arch=(any)
url=https://github.com/berarma/oversteer
@@ -18,12 +18,17 @@ depends=(
python-gobject
python-matplotlib
python-pyudev
- python-scipy
python-pyxdg
+ python-scipy
)
makedepends=(meson)
-source=(${pkgname}-${pkgver}.tar.gz::https://github.com/berarma/${pkgname}/archive/${pkgver}.tar.gz)
-sha256sums=(26479ef8b06da2373d67bbf803fb3e7b12bea37506ad3b9d5a3376b08d225d25)
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/berarma/${pkgname}/archive/v${pkgver}.tar.gz)
+b2sums=(b282ab666a88042cba259f524a81c2d54ac5c1a62456ddae38f494a979c5e33b4b023ed5a4a89ad12bf4125d99b9c710baf4ae106c5b9acd3f4682b8afdcb422)
+
+prepare() {
+ cd ${pkgname}-${pkgver}
+ sed -i "s|version: '0.8.1',|version: '0.8.2',|g" meson.build
+}
build() {
cd ${pkgname}-${pkgver}