summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Shumate2020-07-06 19:04:31 -0500
committerScott Shumate2020-07-06 19:04:31 -0500
commit5ba11397b0790e91a9b83760b50ce5093b06c985 (patch)
tree4589f2675f3e3e41552142428ae4790ef391c1be
downloadaur-5ba11397b0790e91a9b83760b50ce5093b06c985.tar.gz
Initial revision
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
-rw-r--r--gorom.desktop8
4 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..134e8ea6587a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gorom
+ pkgdesc = Manage ROM sets and torrents for game emulators such as MAME.
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/shumatech/gorom
+ arch = x86_64
+ license = GPL
+ makedepends = go
+ makedepends = upx
+ depends = libsciter-gtk
+ options = !strip
+ source = gorom-0.1.1.tar.gz::https://github.com/shumatech/gorom/archive/v0.1.1.tar.gz
+ source = gorom.desktop
+ sha256sums = 332a6073bf9eec12d26240cb45dc90716165a1116f6c32d1654155a666956ce8
+ sha256sums = a04779995686f47e77b04ce5f131f7d530746c9a4d3c42f9011d70f1e381fbcb
+
+pkgname = gorom
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b5bc2aa573e1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5233cbd7c14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Scott Shumate <scott(at)shumatech(dot)com>
+pkgname=gorom
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Manage ROM sets and torrents for game emulators such as MAME."
+arch=(x86_64)
+url="https://github.com/shumatech/gorom"
+license=('GPL')
+depends=('libsciter-gtk')
+makedepends=('go' 'upx')
+options=(!strip)
+source=(${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz
+ gorom.desktop)
+sha256sums=('332a6073bf9eec12d26240cb45dc90716165a1116f6c32d1654155a666956ce8'
+ 'a04779995686f47e77b04ce5f131f7d530746c9a4d3c42f9011d70f1e381fbcb')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ make upx VERSION=v${pkgver}
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ install -TDm644 "${srcdir}/gorom.desktop" "${pkgdir}/usr/share/applications/gorom.desktop"
+ install -TDm644 gui/res/images/gorom.svg "${pkgdir}/usr/share/icons/hicolor/scalable/apps/gorom.svg"
+ install -Dm755 -t "${pkgdir}/usr/bin" bin/gorom bin/goromui
+}
diff --git a/gorom.desktop b/gorom.desktop
new file mode 100644
index 000000000000..12f2ac93b4c8
--- /dev/null
+++ b/gorom.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=GoROM
+GenericName=Emulator ROM Manager
+Icon=/usr/share/icons/hicolor/scalable/apps/gorom.svg
+Exec=/usr/bin/goromui
+StartupNotify=true
+Categories=Application;Utility;Games