summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Rauwolf2015-08-07 11:11:21 -0700
committerKevin Rauwolf2015-08-07 11:11:21 -0700
commit5bb625913beb397bf276f38351c6285db3cbe3d8 (patch)
tree51ec04ed2641d478c62979b326612cf0a781be5e
downloadaur-5bb625913beb397bf276f38351c6285db3cbe3d8.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD62
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c22f273f5ccd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = perl-mail-rfc822-address
+ pkgdesc = Mail::RFC822::Address - Perl extension for validating email addresses according to RFC822
+ pkgver = 0.3
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Mail-RFC822-Address/
+ arch = any
+ license = MIT
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/P/PD/PDWARREN/Mail-RFC822-Address-0.3.tar.gz
+ md5sums = 0bd88b2ffedd95a4a920053fd6d0b709
+
+pkgname = perl-mail-rfc822-address
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54fecaff0812
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# vim:set ts=2 sw=2 et ft=sh tw=100: expandtab
+# Maintainer: Kevin Rauwolf <sweetpea-aur@tentacle.net>
+pkgname=perl-mail-rfc822-address
+pkgver=0.3
+pkgrel=1
+_author="P/PD/PDWARREN"
+_perlmod="Mail-RFC822-Address"
+pkgdesc="Mail::RFC822::Address - Perl extension for validating email addresses according to RFC822"
+arch=('any')
+url="http://search.cpan.org/dist/Mail-RFC822-Address/"
+license=('MIT')
+depends=()
+makedepends=()
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
+
+build(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # Setting these env variables overwrites any command-line-options we don't want...
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ /usr/bin/perl Makefile.PL
+ make
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ /usr/bin/perl Build.PL
+ perl Build
+ fi
+}
+check(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make test
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build test
+ fi
+}
+package(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make install
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build install
+ fi
+
+ # remove perllocal.pod and .packlist
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+md5sums=('0bd88b2ffedd95a4a920053fd6d0b709')