summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Joram2023-01-15 13:06:57 +0200
committerPhilipp Joram2023-01-15 13:33:57 +0200
commit5bba34e9840af9f00ea79281f4db72f15fac57b2 (patch)
tree2c09d4862bcf36b161febc6439ccd07908485059
parentdbdf54d87379b2687b67512eb99b45af7473cdf5 (diff)
downloadaur-5bba34e9840af9f00ea79281f4db72f15fac57b2.tar.gz
Build standard (PEP517) package
See https://wiki.archlinux.org/title/Python_package_guidelines#Standards_based_(PEP_517)
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 449fc87fa8f3..941beaf11627 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,13 +11,18 @@ arch=('any')
url="https://github.com/jaedb/iris"
license=('APACHE')
depends=('mopidy>=3' 'python-configobj' 'python-pylast')
-makedepends=('python-setuptools' 'python-pip')
+makedepends=('python-build' 'python-installer' 'python-wheel')
optdepends=('mopidy-local: local library support'
'mopidy-spotify: spotify support')
source=("${_name}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
sha256sums=('800ebe9e922d8c6d632080d2d4cbdade39d18ceb8eeda5fd4328facf7d52ab42')
+build() {
+ cd "${_name}-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
package() {
cd "${_name}-$pkgver"
- python setup.py install --root="${pkgdir}/" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}