summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilippe Proulx2016-10-31 15:13:44 -0400
committerPhilippe Proulx2016-10-31 15:13:44 -0400
commit5bbc045ea7068281c9858fa0869415c8ee99e1cb (patch)
tree738539b7c15e7f9b8a0f25762b18b496a33cbbe2
downloadaur-5bbc045ea7068281c9858fa0869415c8ee99e1cb.tar.gz
Initial commit: 1.4.0
Signed-off-by: Philippe Proulx <eeppeliteloop@gmail.com>
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD28
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd804f97a428
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Mon Oct 31 19:11:28 UTC 2016
+pkgbase = python-babeltrace
+ pkgdesc = Babeltrace Python bindings
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = http://diamon.org/babeltrace
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ license = GPL2
+ license = MIT
+ makedepends = swig>=2.0.0
+ depends = babeltrace>=1.4.0
+ depends = python
+ options = !libtool
+ source = http://www.efficios.com/files/babeltrace/babeltrace-1.4.0.tar.bz2
+ sha1sums = 3b162480ee883625e8581bf163817f78a4b6487b
+
+pkgname = python-babeltrace
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f2ca44fecba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Philippe Proulx <pproulx@efficios.com>
+
+pkgname=('python-babeltrace')
+pkgver=1.4.0
+pkgrel=1
+pkgdesc='Babeltrace Python bindings'
+arch=('i686' 'x86_64')
+url="http://diamon.org/babeltrace"
+license=('LGPL2.1' 'GPL2' 'MIT')
+source=(http://www.efficios.com/files/babeltrace/babeltrace-${pkgver}.tar.bz2)
+makedepends=('swig>=2.0.0')
+depends=('babeltrace>=1.4.0' 'python')
+options=('!libtool')
+sha1sums=('3b162480ee883625e8581bf163817f78a4b6487b')
+
+build()
+{
+ cd "${srcdir}/babeltrace-${pkgver}"
+ PYTHON=/usr/bin/python PYTHON_CONFIG=/usr/bin/python-config ./configure --prefix=/usr --disable-debug-info --enable-python-bindings
+ make
+}
+
+package() {
+ cd "${srcdir}/babeltrace-${pkgver}/bindings/python"
+ make install DESTDIR="${pkgdir}"
+ cd "${srcdir}/babeltrace-${pkgver}"
+ install -m0644 -D LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}