summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMubashshir2022-10-12 17:31:03 +0600
committerMubashshir2022-10-12 17:32:02 +0600
commit5bf8e8afb722c9f5f3ce186298cc0ea1c800ef6a (patch)
tree26704678c4a88ee5403fc5c9b88ae70e37ef7f89
parent103f57cbc8c67b7c46915a62a8f7925abe53af6e (diff)
downloadaur-5bf8e8afb722c9f5f3ce186298cc0ea1c800ef6a.tar.gz
nginx-mainline-mod-lua: Fix changed struct in nginx-mainline
Signed-off-by: Mubashshir <ahmubashshir@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD9
-rw-r--r--cookie.patch11
4 files changed, 22 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1fbde220c19..360e88b57784 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nginx-mainline-mod-lua
pkgdesc = Lua script engine module for mainline nginx
pkgver = 0.10.22
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://github.com/openresty/lua-nginx-module
arch = i686
@@ -14,6 +14,8 @@ pkgbase = nginx-mainline-mod-lua
depends = lua-resty-core
depends = pcre
source = https://github.com/openresty/lua-nginx-module/archive/v0.10.22/lua-0.10.22.tar.gz
+ source = cookie.patch
sha256sums = 294d3d4b2d14fda1b8c539ff86f90047d203df861eb9a1ac44ec5c679ef55408
+ sha256sums = 774e46d085ca8bd0d7cd84a36946cf1fd31f284ca9ebc90828b758297614975b
pkgname = nginx-mainline-mod-lua
diff --git a/.gitignore b/.gitignore
index 5ddc79664272..6a3f3b8135c5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -17,3 +17,5 @@
*.kate-swp
!.SRCINFO
!PKGBUILD
+!cookie.patch
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 8041cb6caf63..4ef462c4f38a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=nginx-mainline-mod-lua
pkgver=0.10.22
-pkgrel=1
+pkgrel=2
epoch=1
_modname="${pkgname#nginx-mainline-mod-}"
@@ -17,10 +17,13 @@ makedepends=('nginx-mainline-src')
url="https://github.com/openresty/lua-nginx-module"
license=('BSD')
-source=(https://github.com/openresty/$_modname-nginx-module/archive/v$pkgver/$_modname-$pkgver.tar.gz)
-sha256sums=('294d3d4b2d14fda1b8c539ff86f90047d203df861eb9a1ac44ec5c679ef55408')
+source=(https://github.com/openresty/$_modname-nginx-module/archive/v$pkgver/$_modname-$pkgver.tar.gz
+ cookie.patch)
+sha256sums=('294d3d4b2d14fda1b8c539ff86f90047d203df861eb9a1ac44ec5c679ef55408'
+ '774e46d085ca8bd0d7cd84a36946cf1fd31f284ca9ebc90828b758297614975b')
prepare() {
+ patch -d $_modname-nginx-module-$pkgver -p1 < cookie.patch
mkdir -p build
cd build
ln -sf /usr/src/nginx/auto
diff --git a/cookie.patch b/cookie.patch
new file mode 100644
index 000000000000..1ae791bad82a
--- /dev/null
+++ b/cookie.patch
@@ -0,0 +1,11 @@
+--- a/src/ngx_http_lua_headers_in.c 2022-09-15 08:59:08.000000000 +0600
++++ b/src/ngx_http_lua_headers_in.c 2022-10-12 17:27:32.110186592 +0600
+@@ -153,7 +153,7 @@
+ #endif
+
+ { ngx_string("Cookie"),
+- offsetof(ngx_http_headers_in_t, cookies),
++ offsetof(ngx_http_headers_in_t, cookie),
+ ngx_http_set_builtin_multi_header },
+
+ { ngx_null_string, 0, ngx_http_set_header }