summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew O'Neill2021-08-15 21:14:37 -0400
committerAndrew O'Neill2021-08-15 21:14:37 -0400
commit5c19f6406d81639a7bfb51e1bb45cd51808a067c (patch)
treef348cdd75f47c1d3fd192acfee7990b1d85f99c1
parente893e09f8224cd14214ad4d0af15afc446a673f9 (diff)
downloadaur-5c19f6406d81639a7bfb51e1bb45cd51808a067c.tar.gz
Version bump
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--oci-cli.patch33
3 files changed, 22 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f23c41d76bf..1e037eb7f27e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = oci-cli
pkgdesc = Command line interface for Oracle Cloud Infrastructure
- pkgver = 2.26.4
+ pkgver = 3.0.0
pkgrel = 1
url = https://github.com/oracle/oci-cli
arch = x86_64
@@ -22,9 +22,9 @@ pkgbase = oci-cli
depends = python-retrying
depends = python-yaml
optdepends = python-cx_oracle-git: Used by the database service
- source = oci-cli-2.26.4.tar.gz::https://github.com/oracle/oci-cli/archive/v2.26.4.tar.gz
+ source = oci-cli-3.0.0.tar.gz::https://github.com/oracle/oci-cli/archive/v3.0.0.tar.gz
source = oci-cli.patch
- sha256sums = cfae43864a75f6b69130fffdbbb5aea8fe7dfaf2c069a02eee30320697a9477b
- sha256sums = fad3480552b57a37cb21b04b7f38ff4811944cfe72688765f0edea7a0f327812
+ sha256sums = 6d65f78cefa9f374696dd7ae8e77d6515e8c649cdf0e7bcf36a7ae5d7b603bbf
+ sha256sums = 245f5877b41c848896994325ff2056fb040a2bbd86ba6a9877707603dd958fc4
pkgname = oci-cli
diff --git a/PKGBUILD b/PKGBUILD
index 8380ec33a6a8..37ab18faeb4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
pkgname=oci-cli
-pkgver=2.26.4
+pkgver=3.0.0
pkgrel=1
pkgdesc='Command line interface for Oracle Cloud Infrastructure'
arch=('x86_64')
@@ -12,8 +12,8 @@ makedepends=('python-setuptools')
optdepends=('python-cx_oracle-git: Used by the database service')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
"${pkgname}.patch")
-sha256sums=('cfae43864a75f6b69130fffdbbb5aea8fe7dfaf2c069a02eee30320697a9477b'
- 'fad3480552b57a37cb21b04b7f38ff4811944cfe72688765f0edea7a0f327812')
+sha256sums=('6d65f78cefa9f374696dd7ae8e77d6515e8c649cdf0e7bcf36a7ae5d7b603bbf'
+ '245f5877b41c848896994325ff2056fb040a2bbd86ba6a9877707603dd958fc4')
prepare() {
cd "${pkgname}-${pkgver}"
diff --git a/oci-cli.patch b/oci-cli.patch
index 85b4fba5c286..2a6b3c15ff29 100644
--- a/oci-cli.patch
+++ b/oci-cli.patch
@@ -1,16 +1,16 @@
-diff -rupN oci-cli-2.26.4/setup.py oci-cli-2.26.4b/setup.py
---- oci-cli-2.26.4/setup.py 2021-07-27 14:09:09.000000000 -0400
-+++ oci-cli-2.26.4b/setup.py 2021-07-31 16:49:27.323401074 -0400
-@@ -30,23 +30,22 @@ with open_relative("README.rst") as f:
+diff -rupN oci-cli-3.0.0/setup.py oci-cli-3.0.0b/setup.py
+--- oci-cli-3.0.0/setup.py 2021-08-03 15:20:34.000000000 -0400
++++ oci-cli-3.0.0b/setup.py 2021-08-15 21:11:03.420019129 -0400
+@@ -29,23 +29,22 @@ with open_relative("README.rst") as f:
readme = f.read()
requires = [
-- 'oci==2.43.1',
+- 'oci==2.43.2',
- 'arrow==0.17.0',
+ 'oci',
+ 'arrow',
'certifi',
-- 'click==6.7',
+- 'click==7.0',
- 'configparser==4.0.2',
- 'cryptography>=3.2.1,<=3.4.7',
- 'jmespath==0.10.0',
@@ -37,15 +37,12 @@ diff -rupN oci-cli-2.26.4/setup.py oci-cli-2.26.4b/setup.py
}
fips_libcrypto_file = os.getenv("OCI_CLI_FIPS_LIBCRYPTO_FILE")
-diff -rupN oci-cli-2.26.4/src/oci_cli/cli_root.py oci-cli-2.26.4b/src/oci_cli/cli_root.py
---- oci-cli-2.26.4/src/oci_cli/cli_root.py 2021-07-27 14:09:09.000000000 -0400
-+++ oci-cli-2.26.4b/src/oci_cli/cli_root.py 2021-07-31 16:49:45.512918304 -0400
-@@ -307,7 +307,7 @@ For information on configuration, see ht
- @click.option('--profile',
- default=Sentinel(DEFAULT_PROFILE), show_default=False,
- help='The profile in the config file to load. This profile will also be used to locate any default parameter values which have been specified in the OCI CLI-specific configuration file. [default: DEFAULT]')
--@click.option('--cli-rc-file', '--defaults-file',
-+@click.option('--cli-rc-file', '--defaults-file', 'defaults_file',
- default=cli_constants.CLI_RC_DEFAULT_LOCATION, show_default=True,
- is_eager=True, callback=eager_load_cli_rc_file,
- help='The path to the OCI CLI-specific configuration file, containing parameter default values and other configuration information such as command aliases and predefined queries. The --defaults-file option is deprecated and you should use the --cli-rc-file option instead.')
+@@ -90,7 +89,7 @@ setup(
+ packages=all_packages,
+ package_dir=package_dirs,
+ include_package_data=True,
+- python_requires='>=3.6',
++ python_requires='',
+ license="Universal Permissive License 1.0 or Apache License 2.0",
+ classifiers=[
+ "Development Status :: 5 - Production/Stable",