summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHector Mtz-Seara2016-01-18 10:45:13 +0100
committerHector Mtz-Seara2016-01-18 10:45:13 +0100
commit5ca813855a72759300bd009dcaaeb4e31a34af7a (patch)
tree4d00d99437db2e9469183099aae9dca2d75aeea7
parent66456e6db4839b79452b6f649364ebbb7561ffe6 (diff)
downloadaur-5ca813855a72759300bd009dcaaeb4e31a34af7a.tar.gz
Update to 5.0.7-3: Added VMD support and a patch to help changing between gromacs versions
-rw-r--r--.SRCINFO6
-rw-r--r--GMXRC.bash.cmakein.patch14
-rw-r--r--PKGBUILD20
3 files changed, 36 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac775829c8ef..940ad1221c6c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Mon Jan 18 09:43:05 UTC 2016
pkgbase = gromacs-5.0-complete
pkgdesc = A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.
pkgver = 5.0.7
- pkgrel = 2
+ pkgrel = 3
url = http://www.gromacs.org/
arch = i686
arch = x86_64
@@ -15,7 +17,9 @@ pkgbase = gromacs-5.0-complete
depends = libx11
options = !libtool
source = ftp://ftp.gromacs.org/pub/gromacs/gromacs-5.0.7.tar.gz
+ source = GMXRC.bash.cmakein.patch
sha1sums = 29fd9c13874d26c1e18cd45ec74bd2d9be0b78c1
+ sha1sums = 014b2cbfa13db9b495c88f653805c330747117dc
pkgname = gromacs-5.0-complete
diff --git a/GMXRC.bash.cmakein.patch b/GMXRC.bash.cmakein.patch
new file mode 100644
index 000000000000..f0408d787a2e
--- /dev/null
+++ b/GMXRC.bash.cmakein.patch
@@ -0,0 +1,14 @@
+--- GMXRC.bash.cmakein 2013-11-08 13:09:33.000000000 +0200
++++ GMXRC.bash.cmakein.patch 2015-02-20 12:48:10.770670309 +0200
+@@ -4,6 +4,11 @@
+ # This is not 100% necessary, but very useful when we
+ # repeatedly switch between gmx versions in a shell.
+
++#Patch to avoid problems when gromacs is installed using /usr/ as root
++if [ "$GMXLDLIB" == "/usr/lib" ]; then export GMXLDLIB=""; fi
++if [ "$GMXBIN" == "/usr/bin" ]; then export GMXBIN=""; fi
++if [ "$GMXMAN" == "/usr/share/man" ]; then export GMXMAN=""; fi
++
+ # First remove gromacs part of ld_library_path
+ tmppath=""
+ for i in `echo $LD_LIBRARY_PATH | sed "s/:/ /g"`; do
diff --git a/PKGBUILD b/PKGBUILD
index 0ecd2ab0c987..74777544a5e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=gromacs-5.0-complete
pkgver=5.0.7
-pkgrel=2
+pkgrel=3
pkgdesc='A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.'
url='http://www.gromacs.org/'
license=("LGPL")
@@ -11,8 +11,22 @@ arch=('i686' 'x86_64')
depends=('fftw' 'lesstif' 'perl' 'libxml2' 'libsm' 'libx11')
makedepends=('cmake')
options=('!libtool')
-source=(ftp://ftp.gromacs.org/pub/gromacs/gromacs-${pkgver}.tar.gz)
-sha1sums=('29fd9c13874d26c1e18cd45ec74bd2d9be0b78c1')
+source=(ftp://ftp.gromacs.org/pub/gromacs/gromacs-${pkgver}.tar.gz
+ GMXRC.bash.cmakein.patch)
+sha1sums=('29fd9c13874d26c1e18cd45ec74bd2d9be0b78c1'
+ '014b2cbfa13db9b495c88f653805c330747117dc')
+
+export VMDDIR=/usr/lib/vmd/ #If vmd is available at compilation time
+ #Gromacs will have the ability to read any
+ #trajectory file format that can be read by
+ #VMD installation (e.g. AMBER's DCD format).
+
+prepare() {
+cd ${srcdir}/gromacs-${pkgver}/scripts/
+ls
+patch -p0 -i ${srcdir}/GMXRC.bash.cmakein.patch
+}
+
build() {
mkdir -p ${srcdir}/{single,double}