summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2021-07-01 10:01:53 +0200
committerbartus2021-07-01 10:01:53 +0200
commit5cb6bc1aefc3f60a6e3b047adbdf9bbd600b169b (patch)
treea08db2b78b54f89bfa1af33f3d31b98a0c1297fb
parent1030491e708bc222e61f0e1894d8a7356b1dea3a (diff)
downloadaur-5cb6bc1aefc3f60a6e3b047adbdf9bbd600b169b.tar.gz
Pin opencolorio1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--opencolorio1.patch61
3 files changed, 69 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bbc5c61d9649..3455a320af30 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -23,7 +23,7 @@ pkgbase = blender-2.7
depends = freetype2
depends = libxi
depends = openimageio
- depends = opencolorio
+ depends = opencolorio1
depends = openvdb
depends = opencollada
depends = opensubdiv
@@ -47,6 +47,7 @@ pkgbase = blender-2.7
source = openvdb8.patch
source = cycles.patch
source = openexr3.patch
+ source = opencolorio1.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -62,5 +63,6 @@ pkgbase = blender-2.7
sha256sums = edfd784f8497417660c0b9fdc97893fd0d77764d0bc10f4cb92a9082f41bae75
sha256sums = d245f02d73bd5b767ffa49d369383d7cd6ae5e57b89c2975a78c1015e1884864
sha256sums = e7d75a5ef5cb6452b45f6e1e80b6fe69e2630878b1f4f6d53bf0e36ced237712
+ sha256sums = b3fa6ef21383287d0f8e7c3b848f3cf02186f9e3a0e8f194f3ca1323935e5e0e
pkgname = blender-2.7
diff --git a/PKGBUILD b/PKGBUILD
index 98daf6d0ded2..c6e7fde839af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,7 +22,7 @@ pkgdesc="Maintnance version of Blenders ${_branch} branch"
arch=('i686' 'x86_64')
url="https://blender.org/"
depends+=('alembic' 'libgl' 'python' 'python-numpy' 'openjpeg2'
- 'ffmpeg' 'fftw' 'openal' 'freetype2' 'libxi' 'openimageio' 'opencolorio'
+ 'ffmpeg' 'fftw' 'openal' 'freetype2' 'libxi' 'openimageio' 'opencolorio1'
'openvdb' 'opencollada' 'opensubdiv' 'openshadinglanguage' 'libtiff' 'libpng')
makedepends+=('git' 'cmake' 'boost' 'mesa' 'llvm')
provides=('blender-2.7')
@@ -47,6 +47,7 @@ source=("git://git.blender.org/blender.git${_fragment}"
openvdb8.patch # ::${_commit_url}/37889011070ff2ec52159690f652238d2b325185
cycles.patch
openexr3.patch
+ opencolorio1.patch
)
sha256sums=('SKIP'
'SKIP'
@@ -62,7 +63,8 @@ sha256sums=('SKIP'
'c4079c4c142516d9cd476f5a3cafddf4068f0950c3c11ea4da9cf999c5ccc1f9'
'edfd784f8497417660c0b9fdc97893fd0d77764d0bc10f4cb92a9082f41bae75'
'd245f02d73bd5b767ffa49d369383d7cd6ae5e57b89c2975a78c1015e1884864'
- 'e7d75a5ef5cb6452b45f6e1e80b6fe69e2630878b1f4f6d53bf0e36ced237712')
+ 'e7d75a5ef5cb6452b45f6e1e80b6fe69e2630878b1f4f6d53bf0e36ced237712'
+ 'b3fa6ef21383287d0f8e7c3b848f3cf02186f9e3a0e8f194f3ca1323935e5e0e')
pkgver() {
# shellcheck disable=SC2164
@@ -76,7 +78,7 @@ prepare() {
if [ ! -v _cuda_capability ] && grep -q nvidia <(lsmod); then
git -C "$srcdir/blender" apply -v "${srcdir}"/SelectCudaComputeArch.patch
fi
- git -C "$srcdir/blender" apply -v "${srcdir}"/{python3.7,stl_export_iter,python3.{8,9,9_2},openvdb{7,8},cycles,openexr3}.patch
+ git -C "$srcdir/blender" apply -v "${srcdir}"/{python3.7,stl_export_iter,python3.{8,9,9_2},openvdb{7,8},cycles,open{exr3,colorio1}}.patch
}
build() {
diff --git a/opencolorio1.patch b/opencolorio1.patch
new file mode 100644
index 000000000000..89fbbd65455d
--- /dev/null
+++ b/opencolorio1.patch
@@ -0,0 +1,61 @@
+diff --git a/build_files/cmake/Modules/FindOpenColorIO.cmake b/build_files/cmake/Modules/FindOpenColorIO.cmake
+index 090032e06ec..f5db181d73d 100644
+--- a/build_files/cmake/Modules/FindOpenColorIO.cmake
++++ b/build_files/cmake/Modules/FindOpenColorIO.cmake
+@@ -28,7 +28,7 @@ IF(NOT OPENCOLORIO_ROOT_DIR AND NOT $ENV{OPENCOLORIO_ROOT_DIR} STREQUAL "")
+ ENDIF()
+
+ SET(_opencolorio_FIND_COMPONENTS
+- OpenColorIO
++ OpenColorIO1
+ yaml-cpp
+ tinyxml
+ )
+@@ -40,7 +40,7 @@ SET(_opencolorio_SEARCH_DIRS
+
+ FIND_PATH(OPENCOLORIO_INCLUDE_DIR
+ NAMES
+- OpenColorIO/OpenColorIO.h
++ OpenColorIO1/OpenColorIO.h
+ HINTS
+ ${_opencolorio_SEARCH_DIRS}
+ PATH_SUFFIXES
+diff --git a/intern/opencolorio/ocio_impl.cc b/intern/opencolorio/ocio_impl.cc
+index 0e25c89f5d7..f1f99de4bd8 100644
+--- a/intern/opencolorio/ocio_impl.cc
++++ b/intern/opencolorio/ocio_impl.cc
+@@ -26,7 +26,7 @@
+ # pragma warning(push)
+ # pragma warning(disable : 4251 4275)
+ #endif
+-#include <OpenColorIO/OpenColorIO.h>
++#include <OpenColorIO1/OpenColorIO.h>
+ #ifdef _MSC_VER
+ # pragma warning(pop)
+ #endif
+diff --git a/intern/opencolorio/ocio_impl_glsl.cc b/intern/opencolorio/ocio_impl_glsl.cc
+index df6adc8f34b..24d1ec8a871 100644
+--- a/intern/opencolorio/ocio_impl_glsl.cc
++++ b/intern/opencolorio/ocio_impl_glsl.cc
+@@ -40,7 +40,7 @@
+ # pragma warning(push)
+ # pragma warning(disable : 4251 4275)
+ #endif
+-#include <OpenColorIO/OpenColorIO.h>
++#include <OpenColorIO1/OpenColorIO.h>
+ #ifdef _MSC_VER
+ # pragma warning(pop)
+ #endif
+diff --git a/intern/cycles/render/shader.cpp b/intern/cycles/render/shader.cpp
+index 8403a636e1c..54abe4cfa3c 100644
+--- a/intern/cycles/render/shader.cpp
++++ b/intern/cycles/render/shader.cpp
+@@ -35,7 +35,7 @@
+ #include "util/util_murmurhash.h"
+
+ #ifdef WITH_OCIO
+-# include <OpenColorIO/OpenColorIO.h>
++# include <OpenColorIO1/OpenColorIO.h>
+ namespace OCIO = OCIO_NAMESPACE;
+ #endif
+