summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2023-03-30 01:03:33 +0200
committerhaawda2023-03-30 01:03:33 +0200
commit5cd83b81133f1b6cd227457122b1f9d946a59f86 (patch)
treecbd5b91b1838624f20994a2d5ae5ddd9e6bde1b7
parent413eabf77ede5dd54a9d254b7dcaa10fdd50b46d (diff)
downloadaur-5cd83b81133f1b6cd227457122b1f9d946a59f86.tar.gz
redopted and updated
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD32
2 files changed, 20 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ca63c244fb7..16dfc5d79f49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emacs-lucid-git
pkgdesc = GNU Emacs. Official git master.
- pkgver = 27.0.50.r136622
+ pkgver = 30.0.50.165672
pkgrel = 1
url = http://www.gnu.org/software/emacs/
arch = i686
@@ -11,7 +11,6 @@ pkgbase = emacs-lucid-git
depends = alsa-lib
depends = gpm
depends = hicolor-icon-theme
- depends = m17n-lib
depends = libxrandr
depends = libxinerama
depends = librsvg
@@ -20,15 +19,13 @@ pkgbase = emacs-lucid-git
depends = libdbus
depends = libxfixes
depends = jansson
- depends = libmagick
depends = desktop-file-utils
provides = emacs
provides = emacs-seq
conflicts = emacs
options = docs
options = !emptydirs
- source = git://git.savannah.gnu.org/emacs.git
+ source = emacs-git::git+https://git.savannah.gnu.org/git/emacs.git
sha256sums = SKIP
pkgname = emacs-lucid-git
-
diff --git a/PKGBUILD b/PKGBUILD
index c7c1211b8fc7..9e8e266fdc6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,33 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=emacs-lucid-git
-pkgver=27.0.50.r136622
+pkgver=30.0.50.165672
pkgrel=1
pkgdesc="GNU Emacs. Official git master."
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/emacs/"
license=('GPL')
-depends=('alsa-lib' 'gpm' 'hicolor-icon-theme' 'm17n-lib' 'libxrandr'
+depends=('alsa-lib' 'gpm' 'hicolor-icon-theme' 'libxrandr'
'libxinerama' 'librsvg' 'gnutls' 'xaw3d' 'libdbus' 'libxfixes'
- 'jansson' 'libmagick' 'desktop-file-utils')
+ 'jansson' 'desktop-file-utils')
makedepends=('git' 'texlive-core')
conflicts=('emacs')
options=('docs' '!emptydirs')
provides=('emacs' 'emacs-seq')
-source=("git://git.savannah.gnu.org/emacs.git")
+source=("emacs-git::git+https://git.savannah.gnu.org/git/emacs.git")
sha256sums=('SKIP')
pkgver() {
- cd emacs
- _mainver=$(grep AC_INIT configure.ac | sed -e 's/^.\+\ \([0-9]\+\.[0-9]\+\.[0-9]\+\).\+$/\1/')
- printf "%s.r%s" "$(echo $_mainver)" "$(git rev-list --count HEAD)"
+ cd emacs-git
+ printf "%s.%s" \
+ $(grep AC_INIT configure.ac | \
+ awk -F',' '{ gsub("[ \\[\\]]","",$2); print $2 }') \
+ $(git rev-list --count HEAD)
}
build() {
- cd emacs
+ cd emacs-git
[[ -x configure ]] || ( ./autogen.sh git && ./autogen.sh autoconf )
- ac_cv_lib_gif_EGifPutExtensionLast=yes PKG_CONFIG_PATH="/usr/lib/imagemagick/pkgconfig" \
./configure --program-transform-name='s/^ctags$/ctags.emacs/' \
--prefix=/usr \
--sysconfdir=/etc \
@@ -36,20 +37,23 @@ build() {
--mandir=/usr/share/man \
--pdfdir=/usr/share/doc/emacs \
--with-modules \
- --with-xft \
+ --with-cairo \
+ --without-xft \
--without-gconf \
--without-gsettings \
- --with-imagemagick \
+ --without-imagemagick \
--without-xwidgets \
--without-pop \
+ --with-sqlite3 \
--with-gameuser=:games \
+ --with-native-compilation \
--disable-build-details
- make
- make pdf
+ make trampolines
+ make pdf
}
package() {
- cd emacs
+ cd emacs-git
_mainver=$(grep AC_INIT configure.ac | sed -e 's/^.\+\ \([0-9]\+\.[0-9]\+\.[0-9]\+\).\+$/\1/')
make DESTDIR="$pkgdir/" install install-pdf
# fix user/root permissions on usr/share files