summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxantares2015-07-02 11:51:38 +0200
committerxantares2015-07-02 11:51:38 +0200
commit5cf594fd5bc9cad2bbabca899a01fb1b6bbf3ccf (patch)
tree3dc04ccf1c53ad31fb4ff6bca2094e7f346b038e
parent792d272e61cba60a24095ee07c277bcc28f8a56a (diff)
downloadaur-5cf594fd5bc9cad2bbabca899a01fb1b6bbf3ccf.tar.gz
put patch in sources
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43ca35055865..945611dcd0df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,7 +13,9 @@ pkgbase = psp-newlib
options = !strip
options = staticlibs
source = ftp://sourceware.org/pub/newlib/newlib-1.20.0.tar.gz
+ source = https://raw.githubusercontent.com/pspdev/psptoolchain/master/patches/newlib-1.20.0-PSP.patch
md5sums = e5488f545c46287d360e68a801d470e8
+ md5sums = SKIP
pkgname = psp-newlib
diff --git a/PKGBUILD b/PKGBUILD
index 4629cf74f185..e8ac7a41af0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,15 +8,16 @@ license=('GPL')
groups=('psp')
makedepends=('psp-gcc-base' 'psp-binutils' 'psp-sdk-base')
options=('!buildflags' '!strip' 'staticlibs')
-source=("ftp://sourceware.org/pub/newlib/newlib-$pkgver.tar.gz")
-md5sums=('e5488f545c46287d360e68a801d470e8')
+source=("ftp://sourceware.org/pub/newlib/newlib-$pkgver.tar.gz"
+ "https://raw.githubusercontent.com/pspdev/psptoolchain/master/patches/newlib-$pkgver-PSP.patch")
+md5sums=('e5488f545c46287d360e68a801d470e8'
+ 'SKIP')
prepare ()
{
cd "$srcdir/newlib-$pkgver"
rm -rf newlib/libc/sys/psp/
- wget -c https://raw.githubusercontent.com/pspdev/psptoolchain/master/patches/newlib-$pkgver-PSP.patch
- patch -p1 -i newlib-$pkgver-PSP.patch
+ patch -p1 -i "$srcdir"/newlib-$pkgver-PSP.patch
}
build()