summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2016-02-11 09:51:05 +0600
committerKonstantin Shalygin2016-02-11 09:51:05 +0600
commit5d0bc02d92942b461113916eb74a7991d66dee75 (patch)
treecfc284fb37a2c40a38fed5e6c2b89ed908053220
downloadaur-5d0bc02d92942b461113916eb74a7991d66dee75.tar.gz
Import from AUR3
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--LICENSE24
-rw-r--r--Makefile11
-rw-r--r--PKGBUILD43
5 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d195fa6a6db9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Thu Feb 11 03:50:48 UTC 2016
+pkgbase = xidle
+ pkgdesc = xidle runs a program on X inactivity
+ pkgver = 24102005
+ pkgrel = 1
+ url = http://www.freshports.org/x11/xidle
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = libxss
+ depends = libxext
+ depends = libx11
+ source = Makefile
+ source = LICENSE
+ source = http://distcache.freebsd.org/local-distfiles/novel/xidle-24102005.tar.bz2
+ md5sums = acfd0e9b0f8e9d123edd9f7575696981
+ md5sums = fc5e113e43e90e9b23299ee186aca0c8
+ md5sums = 6d4067b5adac594aa5917f2265cc02ee
+
+pkgname = xidle
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d263cd870684
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/*
+src/*
+*.tar.*
+*.zip*
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..781e5142773f
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,24 @@
+$OpenBSD: xidle.c,v 1.10 2005/10/07 19:47:26 fgsch Exp $
+
+Copyright (c) 2005 Federico G. Schwindt.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+
+THIS SOFTWARE IS PROVIDED BY THE OPENBSD PROJECT AND CONTRIBUTORS
+``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE OPENBSD
+PROJECT OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..ead889ff4700
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,11 @@
+PREFIX = /usr
+INSTALL = install
+CFLAGS += -Wall -D__dead=
+FLAGS = $(shell pkg-config --libs --cflags xscrnsaver xext x11)
+
+xidle:
+ $(CC) -o xidle xidle.c $(CFLAGS) $(LDFLAGS) $(FLAGS)
+
+install:
+ $(INSTALL) -D -m 0755 xidle $(DESTDIR)/$(PREFIX)/bin/xidle
+ $(INSTALL) -D -m 0644 xidle.1 $(DESTDIR)/$(PREFIX)/share/man/man1/xidle.1 \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..03e938951d10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: MichaƂ Kazior <kazikcz at gmail dot com>
+pkgname=xidle
+pkgver=24102005
+pkgrel=1
+epoch=
+pkgdesc="xidle runs a program on X inactivity"
+arch=(i686 x86_64)
+url="http://www.freshports.org/x11/xidle"
+license=('BSD')
+groups=()
+depends=(libxss libxext libx11)
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(Makefile LICENSE http://distcache.freebsd.org/local-distfiles/novel/$pkgname-$pkgver.tar.bz2)
+noextract=()
+
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make -f ../Makefile
+}
+
+check() {
+ return 0
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make -f ../Makefile DESTDIR="$pkgdir/" install
+ install -D -m644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+md5sums=('acfd0e9b0f8e9d123edd9f7575696981'
+ 'fc5e113e43e90e9b23299ee186aca0c8'
+ '6d4067b5adac594aa5917f2265cc02ee')