summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2016-03-06 00:47:50 +0300
committerLev Levitsky2016-03-06 00:47:50 +0300
commit5d1b3aa4b3ac431241d45b3183aefd642d299489 (patch)
treef46f9a892007cc7e48aa7e87eb2d7441a3358d60
parentf49e82f2551e02e3866ec479900f887bfa2badba (diff)
downloadaur-5d1b3aa4b3ac431241d45b3183aefd642d299489.tar.gz
Revision 200
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD15
-rw-r--r--morpheus2
-rw-r--r--morpheus.install3
-rw-r--r--morpheus_cl2
5 files changed, 21 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14774e23ecc8..9fd4857adefe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Mar 5 21:47:27 UTC 2016
pkgbase = morpheus
pkgdesc = A mass spectrometry–based proteomics database search algorithm
- pkgver = 142
+ pkgver = 200
pkgrel = 1
url = http://sourceforge.net/projects/morpheus-ms/
+ install = morpheus.install
arch = any
license = MIT
depends = mono
- source = http://sourceforge.net/projects/morpheus-ms/files/revision%20142/Morpheus%20%28Linux%29.tar.gz/download
+ source = http://sourceforge.net/projects/morpheus-ms/files/revision%20200/Morpheus%20%28mzML%20Linux%29.tar.gz/download
source = morpheus_cl
source = morpheus
- md5sums = a999454c980aebf6ea440d914dca9726
- md5sums = d772495a3c9104c94e3273ca36fbac38
- md5sums = da3b2649a397cbbc0e6803160247cc30
+ md5sums = cf12f9244d70d5aee4565dca470cbe1e
+ md5sums = 71ab85a987af41daf56c3b806c53c49b
+ md5sums = 274d39f13400d681af86fa8a51c4e758
pkgname = morpheus
diff --git a/PKGBUILD b/PKGBUILD
index 8284a72ad9fa..742e689341e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,27 @@
# Maintainer: Lev Levitsky <levlev@mail.ru>
pkgname=morpheus
-pkgver=142
+pkgver=200
pkgrel=1
pkgdesc="A mass spectrometry–based proteomics database search algorithm"
arch=('any')
url="http://sourceforge.net/projects/morpheus-ms/"
license=('MIT')
depends=('mono')
-source=("http://sourceforge.net/projects/morpheus-ms/files/revision%20${pkgver}/Morpheus%20%28Linux%29.tar.gz/download"
+source=("http://sourceforge.net/projects/morpheus-ms/files/revision%20${pkgver}/Morpheus%20%28mzML%20Linux%29.tar.gz/download"
"morpheus_cl"
"morpheus")
-md5sums=('a999454c980aebf6ea440d914dca9726'
- 'd772495a3c9104c94e3273ca36fbac38'
- 'da3b2649a397cbbc0e6803160247cc30')
+install=${pkgname}.install
+md5sums=('cf12f9244d70d5aee4565dca470cbe1e'
+ '71ab85a987af41daf56c3b806c53c49b'
+ '274d39f13400d681af86fa8a51c4e758')
package() {
opt="$pkgdir/opt/$pkgname"
install -d "$opt"
install -D "$srcdir/morpheus_cl" "$pkgdir/usr/bin/morpheus_cl"
install -D "$srcdir/morpheus" "$pkgdir/usr/bin/morpheus"
- cp -rT "$srcdir/Morpheus (Linux)" "$opt"
+ cp -rT "$srcdir/Morpheus (mzML Linux)" "$opt"
rm "$opt"/MIT_License.*.txt
install -d "$pkgdir/usr/share/licenses/$pkgname"
- install -t "$pkgdir/usr/share/licenses/$pkgname" "$srcdir/Morpheus (Linux)"/MIT_License.{CommandLine,Morpheus}.txt
+ install -t "$pkgdir/usr/share/licenses/$pkgname" "$srcdir/Morpheus (mzML Linux)"/MIT_License.{CommandLine,Morpheus}.txt
}
diff --git a/morpheus b/morpheus
index eb94936bc565..b6a24bc83248 100644
--- a/morpheus
+++ b/morpheus
@@ -1,2 +1,2 @@
#!/usr/bin/sh
-mono /opt/morpheus/Morpheus.exe "$@"
+mono '/opt/morpheus/Morpheus %28mzML Mono%29.exe' "$@"
diff --git a/morpheus.install b/morpheus.install
new file mode 100644
index 000000000000..dfb15ae0286e
--- /dev/null
+++ b/morpheus.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo "Run 'morpheus' for GUI version and 'morpheus_cl' for command line version."
+}
diff --git a/morpheus_cl b/morpheus_cl
index 2428507ca27f..2fa0211a9ab2 100644
--- a/morpheus_cl
+++ b/morpheus_cl
@@ -1,2 +1,2 @@
#!/usr/bin/sh
-mono /opt/morpheus/morpheus_cl.exe "$@"
+mono /opt/morpheus/morpheus_mzml_mono_cl.exe "$@"