summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManoel Vilela2018-02-17 04:00:42 -0300
committerManoel Vilela2018-02-17 04:00:42 -0300
commit5d21cc1250009d21ad624b9f8203cf7ac78237c6 (patch)
tree89d7e18607b8ceeb5fb93c41cc44f9760fdb81ee
parente9711222ecb189e0d28aa2ebc59dce4064fbd7a5 (diff)
downloadaur-5d21cc1250009d21ad624b9f8203cf7ac78237c6.tar.gz
Add support to dbus on emacs-daemon
This should expor variables about dbus in the mean time of start the service. This should not work as service when is started before the X server, however. I use this shit to get notifications working on erc-mode.
-rw-r--r--PKGBUILD4
-rwxr-xr-xemacs-daemon.rc12
2 files changed, 14 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ba058a83b8d8..e46f1b4976a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Manoel Vilela <manoel_vilela@engineer.com>
pkgname="emacs-openrc"
-pkgver="1.0"
+pkgver="1.1"
pkgrel=5
pkgdesc="OpenRC emacs-daemon init script"
arch=('i686' 'x86_64')
@@ -18,7 +18,7 @@ options=()
install="$pkgname.install"
changelog="CHANGELOG"
source=("emacs-daemon.rc")
-md5sums=('99e69c5e740bcece750ce19574be0223')
+md5sums=('3c64ace1a95c705725d78498847f6d8e')
package() {
# Creating need directories
diff --git a/emacs-daemon.rc b/emacs-daemon.rc
index 1a72f733daa3..5c8f661a6b31 100755
--- a/emacs-daemon.rc
+++ b/emacs-daemon.rc
@@ -46,6 +46,18 @@ start() {
checkconfig || return 1
eval HOME="~${USER}"
+
+ # parsing files of session
+ ebegin "Fetching dbus address..."
+ for file in $(ls -d -1 $HOME/.dbus/session-bus/**-0)
+ do
+ echo $file
+ cat $file
+ source $file
+ done
+
+ export DBUS_SESSION_BUS_ADDRESS
+
ebegin "Starting Emacs daemon for user ${USER}"
start-stop-daemon --start \
--chdir ${HOME} \