summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2023-06-10 11:27:47 +0200
committerFabioLolix2023-06-10 11:27:47 +0200
commit5d21efb8ad30169a3bd3ca60d896576e29b688dc (patch)
treefde38d18e7ceef32c5e8eae6f2e4cb6a421bceb5
parent1df8247e9844946368a44b9bc7b131bab54926b6 (diff)
downloadaur-5d21efb8ad30169a3bd3ca60d896576e29b688dc.tar.gz
fix build with gcc13.1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4625c363bc0d..7882a26fe707 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nemu
pkgdesc = ncurses interface for QEMU
pkgver = 3.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/nemuTUI/nemu
arch = i686
arch = x86_64
@@ -18,6 +18,8 @@ pkgbase = nemu
depends = libarchive
depends = bash
source = git+https://github.com/nemuTUI/nemu.git#tag=v3.2.0
+ source = nemu-fix-compiler-flags.patch::https://github.com/nemuTUI/nemu/commit/e8c206775e8fb288d79fdc73d703e05d8e93ed31.patch
sha256sums = SKIP
+ sha256sums = e831c072932e1f2c33ad30ed1600352aa5a3c6d8aab990dc44624ef2718142bb
pkgname = nemu
diff --git a/PKGBUILD b/PKGBUILD
index 85d5e8b36721..29dd6775d065 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,22 @@
pkgname=nemu
pkgver=3.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="ncurses interface for QEMU"
arch=(i686 x86_64)
url="https://github.com/nemuTUI/nemu"
license=(BSD)
depends=(qemu ncurses sqlite udev libusb json-c libxml2 libarchive bash)
makedepends=(git cmake)
-source=("git+https://github.com/nemuTUI/nemu.git#tag=v${pkgver}")
-sha256sums=('SKIP')
+source=("git+https://github.com/nemuTUI/nemu.git#tag=v${pkgver}"
+ "nemu-fix-compiler-flags.patch::https://github.com/nemuTUI/nemu/commit/e8c206775e8fb288d79fdc73d703e05d8e93ed31.patch")
+sha256sums=('SKIP'
+ 'e831c072932e1f2c33ad30ed1600352aa5a3c6d8aab990dc44624ef2718142bb')
prepare() {
cd "${pkgname}"
[[ -d build ]] || mkdir build
+ patch -Np1 -i ../nemu-fix-compiler-flags.patch
}
build() {