summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122015-06-08 12:10:02 +0200
committerwillemw122015-06-08 12:10:02 +0200
commit5d4c45a7ff7d60e583d92e187f72d86dcee8de2e (patch)
tree7cb7ff8807ef241786a0330c2a2f0ad882fe7e31
downloadaur-5d4c45a7ff7d60e583d92e187f72d86dcee8de2e.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD36
-rw-r--r--iwscanner19
-rw-r--r--iwscanner.desktop8
-rw-r--r--setup.py33
5 files changed, 121 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b25da5769d31
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = iwscanner
+ pkgdesc = Wireless scanner with an easy to use graphic interface and using the iwlist tool
+ pkgver = 0.2.4
+ pkgrel = 3
+ url = http://kuthulu.com/iwscanner
+ arch = any
+ license = LGPL
+ depends = pygtk
+ depends = python2
+ depends = wireless_tools
+ optdepends = gksu: privilege escalation to use wireless tools
+ optdepends = kdesu: privilege escalation to use wireless tools
+ optdepends = gksudo: privilege escalation to use wireless tools
+ options = !emptydirs
+ source = http://kuthulu.com/iwscanner/iwscanner-0.2.4.tgz
+ source = iwscanner
+ source = iwscanner.desktop
+ source = setup.py
+ md5sums = f26ce8196f992ad3e60b1af758be1546
+ md5sums = 7dcbc65395faba817a3653db7d07224a
+ md5sums = d0613547024a89444c34ef2b34d8427c
+ md5sums = dc0f19ef1682331df54eaec0ad8d6dc0
+
+pkgname = iwscanner
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..648b1c1c43af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: willemw <willemw12@gmail.com>
+
+pkgname=iwscanner
+pkgver=0.2.4
+pkgrel=3
+pkgdesc="Wireless scanner with an easy to use graphic interface and using the iwlist tool"
+arch=('any')
+url="http://kuthulu.com/iwscanner"
+license=('LGPL')
+depends=('pygtk' 'python2' 'wireless_tools')
+optdepends=('gksu: privilege escalation to use wireless tools'
+ 'kdesu: privilege escalation to use wireless tools'
+ 'gksudo: privilege escalation to use wireless tools')
+options=(!emptydirs)
+# Additional source files are based on the opensuse 'iwscanner' rpm
+source=(http://kuthulu.com/iwscanner/iwscanner-$pkgver.tgz
+ iwscanner
+ iwscanner.desktop
+ setup.py)
+md5sums=('f26ce8196f992ad3e60b1af758be1546'
+ '7dcbc65395faba817a3653db7d07224a'
+ 'd0613547024a89444c34ef2b34d8427c'
+ 'dc0f19ef1682331df54eaec0ad8d6dc0')
+
+prepare() {
+ cd $pkgname-$pkgver
+ sed -i 's|#!/usr/bin/env python[ ]*$|#!/usr/bin/env python2|' iwscanner.py
+}
+
+package() {
+ install -Dm644 iwscanner.desktop "$pkgdir/usr/share/applications/iwscanner.desktop"
+
+ cd $pkgname-$pkgver
+ python2 ../../setup.py install --root="$pkgdir/" --optimize=1
+}
+
diff --git a/iwscanner b/iwscanner
new file mode 100644
index 000000000000..b4ffe4a1cf70
--- /dev/null
+++ b/iwscanner
@@ -0,0 +1,19 @@
+#!/bin/sh
+#Simple script to start iwscanner
+
+GKSU=/usr/bin/gksu
+KDESU=/usr/bin/kdesu
+GKSUDO=/usr/bin/gksudo
+
+if [ -e "$GKSU" ]
+ then
+ $GKSU /usr/share/iwscanner/iwscanner.py
+elif [ -e "$KDESU" ]
+ then
+ $KDESU -c /usr/share/iwscanner/iwscanner.py
+elif [ -e "$GKSUDO" ]
+ then
+ $GKSUDO -c /usr/share/iwscanner/iwscanner.py
+else
+ echo "Unable to find suitable su application, please install gksu"
+fi
diff --git a/iwscanner.desktop b/iwscanner.desktop
new file mode 100644
index 000000000000..385ade4d4793
--- /dev/null
+++ b/iwscanner.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=iwscanner
+Comment=Wireless scanner for linux
+Categories=GTK;Network;Monitor;
+Exec=iwscanner
+Icon=iwscanner
+Terminal=false
+Type=Application
diff --git a/setup.py b/setup.py
new file mode 100644
index 000000000000..df00885cc1d2
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,33 @@
+#!/usr/bin/env python2
+
+from distutils.core import setup
+from fnmatch import fnmatch
+import os
+
+def listfiles(*dirs):
+ dir, pattern = os.path.split(os.path.join(*dirs))
+ return [os.path.join(dir, filename)
+ for filename in os.listdir(os.path.abspath(dir))
+ if filename[0] != '.' and fnmatch(filename, pattern)]
+
+setup(
+ name = 'iwscanner',
+ version = '0.2.4',
+ description = 'Wireless Scanner',
+ long_description = "Wireless scanner for linux with an easy to use graphic interface",
+ author = 'Renzo Bertuzzi (kuthulu)',
+ author_email = 'iwscanner@kuthulu.com',
+ url = 'http://www.kuthulu.com/iwscanner',
+ platforms = 'linux',
+ license = 'LGPL-2.1+',
+ scripts = ['../../iwscanner'],
+ data_files = [
+ ('/usr/share/iwscanner/', [ 'iwscanner.glade' ] ),
+ ('/usr/share/iwscanner/', [ 'iwscanner.py' ] ),
+ ('/usr/share/iwscanner/', [ 'SimpleGladeApp.py' ] ),
+ ('/usr/share/iwscanner/',[ 'iwscanner.png' ] ),
+ ('/usr/share/pixmaps/', [ 'iwscanner.png' ] )
+ ],
+ )
+
+