summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume ALAUX2016-10-29 18:07:41 +0200
committerGuillaume ALAUX2016-10-29 18:09:00 +0200
commit5d5f6a24278af366ec62d587f334fde6d833691e (patch)
tree09233ea6d22e4ec96e2e8a7c20e474bee99ac772
parenta8eaed6ba80c564b0b4637004609dcf5bfeac3dd (diff)
downloadaur-5d5f6a24278af366ec62d587f334fde6d833691e.tar.gz
Add comment on expected start scripts result code
-rw-r--r--PKGBUILD6
-rw-r--r--systemd_storm-nimbus.service4
-rw-r--r--systemd_storm-supervisor.service4
-rw-r--r--systemd_storm-ui.service4
4 files changed, 15 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 60063510a7ad..2c623b3dc488 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -55,9 +55,9 @@ sha256sums=('b3fd2475e88e4b5e30f0e47eab70363419d67c15ddc7fe1f3c423ac0499eb76e'
'SKIP'
'c94799f4b459f5218faf1da57936baeb4c32b9542a1ba0aacdd637bf2f3aaf05'
'00780ee4cea3bb7a282a548f41b8964d5e392776f9d687ebea89cd49ed5742e3'
- '0d8958786538714da86ccf3f23cb668fa017530f8858aea2b7325ffe1af66cd1'
- '894b41bd473410271337585509fe9db431a74f3ae2114039229a5742214e097e'
- '41eade47c4e3b07c53c84351730b1f8752341eed095b6b6fc499ccc2213bead3'
+ '2dafe9352ed01fbe0c74ec6e29e0233a842c4fead7af38cd3540bf69c93a895c'
+ '5decdfb42d6f1b50c21df1c36072bf1c97d0553a23c29536ea020a31210535ce'
+ 'a27a90bae3d948a6cf65732c43b92c735f8dbaa707ab7dfd9f7c74e4fe42f3ba'
'66db40103bc75bae0817581ef1bbde35bb3b81c2494eda5a8c769813ddd000f1'
'15c959356f32c9583fe6a328d2ec4c7addb983ac7a2529621d90c24b49a07df3'
'94567fe94f4d27b1a82714231c0fa9a87827343f3838f9a962e3483f6c6d26a5')
diff --git a/systemd_storm-nimbus.service b/systemd_storm-nimbus.service
index f63285175ca8..dea5a111c79a 100644
--- a/systemd_storm-nimbus.service
+++ b/systemd_storm-nimbus.service
@@ -6,6 +6,10 @@ After=network.target zookeeper@storm.service
[Service]
User=storm
Group=storm
+# The regular way for Systemd to stop the daemon is to send SIGTERM (15)
+# to the underlying process spawned by the `ExecStart` script.
+# When done, the underlying process will thus return 15 to its parent script
+# which will itself return 128+15=143 (See `man bash`)
SuccessExitStatus=143
ExecStart=/usr/bin/storm nimbus
diff --git a/systemd_storm-supervisor.service b/systemd_storm-supervisor.service
index 5b5b09a27c2e..b602320e3b7f 100644
--- a/systemd_storm-supervisor.service
+++ b/systemd_storm-supervisor.service
@@ -6,6 +6,10 @@ After=network.target zookeeper@storm.service
[Service]
User=storm
Group=storm
+# The regular way for Systemd to stop the daemon is to send SIGTERM (15)
+# to the underlying process spawned by the `ExecStart` script.
+# When done, the underlying process will thus return 15 to its parent script
+# which will itself return 128+15=143 (See `man bash`)
SuccessExitStatus=143
ExecStart=/usr/bin/storm supervisor
diff --git a/systemd_storm-ui.service b/systemd_storm-ui.service
index af77c75ea65d..3fba915bef7a 100644
--- a/systemd_storm-ui.service
+++ b/systemd_storm-ui.service
@@ -6,6 +6,10 @@ After=network.target storm-nimbus.service
[Service]
User=storm
Group=storm
+# The regular way for Systemd to stop the daemon is to send SIGTERM (15)
+# to the underlying process spawned by the `ExecStart` script.
+# When done, the underlying process will thus return 15 to its parent script
+# which will itself return 128+15=143 (See `man bash`)
SuccessExitStatus=143
ExecStart=/usr/bin/storm ui