summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112016-02-26 21:34:52 +0100
committerjose17112016-02-26 21:34:52 +0100
commit5d770af50cd0d13f6078502821d801a10b9e361f (patch)
tree6957f4549b276b71cdcf240881aeb1a36dd5e9af
parent6a9c4c28307f39ee7b83344b0e4d3918118b327b (diff)
downloadaur-5d770af50cd0d13f6078502821d801a10b9e361f.tar.gz
fixed man page + 64bit patch added
-rw-r--r--.SRCINFO6
-rw-r--r--64bit.patch18
-rw-r--r--PKGBUILD14
3 files changed, 32 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c7e7187a1953..8ddacdb66cc1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
# Generated by mksrcinfo v8
-# Fri Dec 11 09:12:06 UTC 2015
+# Fri Feb 26 20:34:32 UTC 2016
pkgbase = libdes
pkgdesc = library for DES encryption
pkgver = 4.04b
- pkgrel = 2
+ pkgrel = 3
url = http://linux.maruhn.com/sec/libdes.html
arch = i686
arch = x86_64
license = custom
depends = glibc
source = ftp://ftp.kfki.hu/pub/packages/security/ssh/ossh/libdes-4.04b.tar.gz
+ source = 64bit.patch
md5sums = c8d5c69f86c2eedb485583b0305284a1
+ md5sums = ff48812c1fe870603bf73d441fa6a2e8
pkgname = libdes
diff --git a/64bit.patch b/64bit.patch
new file mode 100644
index 000000000000..61bd6fd250bc
--- /dev/null
+++ b/64bit.patch
@@ -0,0 +1,18 @@
+--- des.h.orig 2016-02-26 21:31:07.204547590 +0100
++++ des.h 2016-02-26 21:32:19.964190512 +0100
+@@ -72,11 +72,14 @@
+ #endif
+
+ #include <stdio.h>
++#include <stdint.h>
+
+ /* If this is set to 'unsigned int' on a DEC Alpha, this gives about a
+ * %20 speed up (longs are 8 bytes, int's are 4). */
++/* On PCs with 64-bit Linux 'unsigned long' doesn't work, 'destest'
++ * fails. 'unsigned int' or 'uint32_t' is needed. */
+ #ifndef DES_LONG
+-#define DES_LONG unsigned long
++#define DES_LONG uint32_t
+ #endif
+
+ typedef unsigned char des_cblock[8];
diff --git a/PKGBUILD b/PKGBUILD
index 3ae09d01e99b..cd28fbcff641 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,30 @@
# Maintainer: Jozef Riha <jose1711 at gmail dot com>
# Contributor: fluke
+# Contributor: thse
pkgname=libdes
pkgver=4.04b
-pkgrel=2
+pkgrel=3
pkgdesc="library for DES encryption"
arch=('i686' 'x86_64')
url="http://linux.maruhn.com/sec/libdes.html"
license=('custom')
depends=('glibc')
-source=(ftp://ftp.kfki.hu/pub/packages/security/ssh/ossh/libdes-4.04b.tar.gz)
-md5sums=('c8d5c69f86c2eedb485583b0305284a1')
+source=(ftp://ftp.kfki.hu/pub/packages/security/ssh/ossh/libdes-4.04b.tar.gz 64bit.patch)
+md5sums=('c8d5c69f86c2eedb485583b0305284a1'
+ 'ff48812c1fe870603bf73d441fa6a2e8')
build() {
cd $srcdir/des
+ if [ $CARCH = 'x86_64' ]
+ then
+ patch -p0 <$srcdir/64bit.patch
+ fi
make
}
package() {
- mkdir -p $pkgdir/usr/lib $pkgdir/usr/bin $pkgdir/usr/include $pkgdir/usr/share/man/man1
+ mkdir -p $pkgdir/usr/lib $pkgdir/usr/bin $pkgdir/usr/include $pkgdir/usr/share/man/man{1,3}
cd $srcdir/des
make LIBDIR=$pkgdir/usr/lib BINDIR=$pkgdir/usr/bin INCDIR=$pkgdir/usr/include MANDIR=$pkgdir/usr/share/man install
}