summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFélix Piédallu2021-01-04 16:48:15 +0100
committerFélix Piédallu2021-01-04 16:48:15 +0100
commit5d8215331d2b2720d9fa2fa1f3a177bf9c3e7d6c (patch)
tree5f16ace4678e11019da229f9a16a1a8a90c338c2
parentb06125c13326e0e6a61fc53ec8bdb747c927be39 (diff)
downloadaur-5d8215331d2b2720d9fa2fa1f3a177bf9c3e7d6c.tar.gz
Add patches for boost 1.75.0. Remove deprecation warnings.
-rw-r--r--PKGBUILD13
-rw-r--r--patch_boost_placeholders.patch169
-rw-r--r--patch_std_gnupp14.patch15
3 files changed, 195 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c57e2ab3f086..93d440c712f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Salamandar <felix@piedallu.me>
pkgname=freecad-linkstage3-git
-pkgver=asm3.0.11.r3384.g405243723c
+pkgver=asm3.0.11.r3435.gb7d3346e00
pkgrel=1
pkgdesc='A general purpose 3D CAD modeler - LinkStage3 dev branch, git checkout'
arch=('x86_64')
@@ -48,9 +48,13 @@ optdepends=(
_gitname='FreeCAD'
source=(
"git+https://github.com/realthunder/FreeCAD.git#branch=LinkStage3"
+ 'patch_std_gnupp14.patch'
+ 'patch_boost_placeholders.patch'
)
sha256sums=(
'SKIP'
+ 'd2a3a4c157741089c5ffbdd7c502be04414b8256081cd01208c94f2b0ed06ce3'
+ '84b9f47fd643a5b01a9b5af8bd1e75c94842d8b564613286e2f145a85793a91e'
)
@@ -61,7 +65,8 @@ pkgver() {
prepare() {
cd "${srcdir}/${_gitname}"
-
+ git apply < "$srcdir/patch_std_gnupp14.patch"
+ git apply < "$srcdir/patch_boost_placeholders.patch"
}
build() {
@@ -71,6 +76,10 @@ build() {
mkdir build -p
pushd build >/dev/null
+ # Those deprecation warnings make debugging a nightmare
+ export CFLAGS="$CFLAGS -Wno-deprecated-declarations"
+ export CXXFLAGS="$CXXFLAGS -Wno-deprecated-declarations"
+
cmake -GNinja -Wno-dev .. \
-DBUILD_QT5=ON \
-DCMAKE_BUILD_TYPE=Release \
diff --git a/patch_boost_placeholders.patch b/patch_boost_placeholders.patch
new file mode 100644
index 000000000000..5c47af2c98cc
--- /dev/null
+++ b/patch_boost_placeholders.patch
@@ -0,0 +1,169 @@
+diff --git a/src/Mod/PartDesign/Gui/Command.cpp b/src/Mod/PartDesign/Gui/Command.cpp
+index bb9f5d0682..aa2cfe088b 100644
+--- a/src/Mod/PartDesign/Gui/Command.cpp
++++ b/src/Mod/PartDesign/Gui/Command.cpp
+@@ -377,7 +377,7 @@ CmdPartDesignSubShapeBinder::CmdPartDesignSubShapeBinder()
+ sPixmap = "PartDesign_SubShapeBinder";
+
+ Gui::Application::Instance->commandManager().registerCallback(
+- boost::bind(&commandOverride, this, 0, _1, _2), "Part_MakeFace");
++ boost::bind(&commandOverride, this, 0, boost::placeholders::_1, boost::placeholders::_2), "Part_MakeFace");
+ }
+
+ void CmdPartDesignSubShapeBinder::activated(int iMsg)
+@@ -1278,7 +1278,7 @@ CmdPartDesignPad::CmdPartDesignPad()
+ sPixmap = "PartDesign_Pad";
+
+ Gui::Application::Instance->commandManager().registerCallback(
+- boost::bind(&commandOverride, this, 0, _1, _2), "Part_Extrude");
++ boost::bind(&commandOverride, this, 0, boost::placeholders::_1, boost::placeholders::_2), "Part_Extrude");
+ }
+
+ void CmdPartDesignPad::activated(int iMsg)
+@@ -1476,7 +1476,7 @@ CmdPartDesignRevolution::CmdPartDesignRevolution()
+ sPixmap = "PartDesign_Revolution";
+
+ Gui::Application::Instance->commandManager().registerCallback(
+- boost::bind(&commandOverride, this, 0, _1, _2), "Part_MakeRevolve");
++ boost::bind(&commandOverride, this, 0, boost::placeholders::_1, boost::placeholders::_2), "Part_MakeRevolve");
+ }
+
+ void CmdPartDesignRevolution::activated(int iMsg)
+@@ -1603,7 +1603,7 @@ CmdPartDesignAdditivePipe::CmdPartDesignAdditivePipe()
+ sPixmap = "PartDesign_Additive_Pipe";
+
+ Gui::Application::Instance->commandManager().registerCallback(
+- boost::bind(&commandOverride, this, 0, _1, _2), "Part_Sweep");
++ boost::bind(&commandOverride, this, 0, boost::placeholders::_1, boost::placeholders::_2), "Part_Sweep");
+ }
+
+ void CmdPartDesignAdditivePipe::activated(int iMsg)
+@@ -1706,7 +1706,7 @@ CmdPartDesignAdditiveLoft::CmdPartDesignAdditiveLoft()
+ sPixmap = "PartDesign_Additive_Loft";
+
+ Gui::Application::Instance->commandManager().registerCallback(
+- boost::bind(&commandOverride, this, 0, _1, _2), "Part_Loft");
++ boost::bind(&commandOverride, this, 0, boost::placeholders::_1, boost::placeholders::_2), "Part_Loft");
+ }
+
+ void CmdPartDesignAdditiveLoft::activated(int iMsg)
+@@ -1907,7 +1907,7 @@ CmdPartDesignFillet::CmdPartDesignFillet()
+ sPixmap = "PartDesign_Fillet";
+
+ Gui::Application::Instance->commandManager().registerCallback(
+- boost::bind(&commandOverride, this, 0, _1, _2), "Part_Fillet");
++ boost::bind(&commandOverride, this, 0, boost::placeholders::_1, boost::placeholders::_2), "Part_Fillet");
+ }
+
+ void CmdPartDesignFillet::activated(int iMsg)
+@@ -1938,7 +1938,7 @@ CmdPartDesignChamfer::CmdPartDesignChamfer()
+ sPixmap = "PartDesign_Chamfer";
+
+ Gui::Application::Instance->commandManager().registerCallback(
+- boost::bind(&commandOverride, this, 0, _1, _2), "Part_Chamfer");
++ boost::bind(&commandOverride, this, 0, boost::placeholders::_1, boost::placeholders::_2), "Part_Chamfer");
+ }
+
+ void CmdPartDesignChamfer::activated(int iMsg)
+@@ -2027,7 +2027,7 @@ CmdPartDesignThickness::CmdPartDesignThickness()
+ sPixmap = "PartDesign_Thickness";
+
+ Gui::Application::Instance->commandManager().registerCallback(
+- boost::bind(&commandOverride, this, 0, _1, _2), "Part_Thickness");
++ boost::bind(&commandOverride, this, 0, boost::placeholders::_1, boost::placeholders::_2), "Part_Thickness");
+ }
+
+ void CmdPartDesignThickness::activated(int iMsg)
+@@ -2144,7 +2144,7 @@ CmdPartDesignMirrored::CmdPartDesignMirrored()
+ sPixmap = "PartDesign_Mirrored";
+
+ Gui::Application::Instance->commandManager().registerCallback(
+- boost::bind(&commandOverride, this, 0, _1, _2), "Part_Mirror");
++ boost::bind(&commandOverride, this, 0, boost::placeholders::_1, boost::placeholders::_2), "Part_Mirror");
+ }
+
+ void CmdPartDesignMirrored::activated(int iMsg)
+@@ -2536,13 +2536,13 @@ CmdPartDesignBoolean::CmdPartDesignBoolean()
+ sPixmap = "PartDesign_Boolean";
+
+ Gui::Application::Instance->commandManager().registerCallback(
+- boost::bind(&commandOverride, this, 0, _1, _2), "Part_Boolean");
++ boost::bind(&commandOverride, this, 0, boost::placeholders::_1, boost::placeholders::_2), "Part_Boolean");
+
+ Gui::Application::Instance->commandManager().registerCallback(
+- boost::bind(&commandOverride, this, 1, _1, _2), "Part_Cut");
++ boost::bind(&commandOverride, this, 1, boost::placeholders::_1, boost::placeholders::_2), "Part_Cut");
+
+ Gui::Application::Instance->commandManager().registerCallback(
+- boost::bind(&commandOverride, this, 2, _1, _2), "Part_Common");
++ boost::bind(&commandOverride, this, 2, boost::placeholders::_1, boost::placeholders::_2), "Part_Common");
+ }
+
+
+@@ -2685,16 +2685,16 @@ CmdPartDesignSplit::CmdPartDesignSplit()
+ sPixmap = "PartDesign_Split";
+
+ Gui::Application::Instance->commandManager().registerCallback(
+- boost::bind(&commandOverride, this, 1, _1, _2), "Part_BooleanFragments");
++ boost::bind(&commandOverride, this, 1, boost::placeholders::_1, boost::placeholders::_2), "Part_BooleanFragments");
+
+ Gui::Application::Instance->commandManager().registerCallback(
+- boost::bind(&commandOverride, this, 0, _1, _2), "Part_Slice");
++ boost::bind(&commandOverride, this, 0, boost::placeholders::_1, boost::placeholders::_2), "Part_Slice");
+
+ Gui::Application::Instance->commandManager().registerCallback(
+- boost::bind(&commandOverride, this, 0, _1, _2), "Part_SliceApart");
++ boost::bind(&commandOverride, this, 0, boost::placeholders::_1, boost::placeholders::_2), "Part_SliceApart");
+
+ Gui::Application::Instance->commandManager().registerCallback(
+- boost::bind(&commandOverride, this, 0, _1, _2), "Part_ExplodeCompound");
++ boost::bind(&commandOverride, this, 0, boost::placeholders::_1, boost::placeholders::_2), "Part_ExplodeCompound");
+ }
+
+ void CmdPartDesignSplit::activated(int iMsg)
+diff --git a/src/Mod/PartDesign/Gui/CommandPrimitive.cpp b/src/Mod/PartDesign/Gui/CommandPrimitive.cpp
+index 397e38fcac..e6a6fb0b10 100644
+--- a/src/Mod/PartDesign/Gui/CommandPrimitive.cpp
++++ b/src/Mod/PartDesign/Gui/CommandPrimitive.cpp
+@@ -85,15 +85,15 @@ CmdPrimtiveCompAdditive::CmdPrimtiveCompAdditive()
+ eType = ForEdit;
+
+ Gui::Application::Instance->commandManager().registerCallback(
+- boost::bind(&commandOverride, this, 0, false, _1, _2), "Part_Box");
++ boost::bind(&commandOverride, this, 0, false, boost::placeholders::_1, boost::placeholders::_2), "Part_Box");
+ Gui::Application::Instance->commandManager().registerCallback(
+- boost::bind(&commandOverride, this, 1, false, _1, _2), "Part_Cylinder");
++ boost::bind(&commandOverride, this, 1, false, boost::placeholders::_1, boost::placeholders::_2), "Part_Cylinder");
+ Gui::Application::Instance->commandManager().registerCallback(
+- boost::bind(&commandOverride, this, 2, false, _1, _2), "Part_Sphere");
++ boost::bind(&commandOverride, this, 2, false, boost::placeholders::_1, boost::placeholders::_2), "Part_Sphere");
+ Gui::Application::Instance->commandManager().registerCallback(
+- boost::bind(&commandOverride, this, 3, false, _1, _2), "Part_Cone");
++ boost::bind(&commandOverride, this, 3, false, boost::placeholders::_1, boost::placeholders::_2), "Part_Cone");
+ Gui::Application::Instance->commandManager().registerCallback(
+- boost::bind(&commandOverride, this, 5, false, _1, _2), "Part_Torus");
++ boost::bind(&commandOverride, this, 5, false, boost::placeholders::_1, boost::placeholders::_2), "Part_Torus");
+ }
+
+ void CmdPrimtiveCompAdditive::activated(int iMsg)
+@@ -267,15 +267,15 @@ CmdPrimtiveCompSubtractive::CmdPrimtiveCompSubtractive()
+ eType = ForEdit;
+
+ Gui::Application::Instance->commandManager().registerCallback(
+- boost::bind(&commandOverride, this, 0, true, _1, _2), "Part_Box");
++ boost::bind(&commandOverride, this, 0, true, boost::placeholders::_1, boost::placeholders::_2), "Part_Box");
+ Gui::Application::Instance->commandManager().registerCallback(
+- boost::bind(&commandOverride, this, 1, true, _1, _2), "Part_Cylinder");
++ boost::bind(&commandOverride, this, 1, true, boost::placeholders::_1, boost::placeholders::_2), "Part_Cylinder");
+ Gui::Application::Instance->commandManager().registerCallback(
+- boost::bind(&commandOverride, this, 2, true, _1, _2), "Part_Sphere");
++ boost::bind(&commandOverride, this, 2, true, boost::placeholders::_1, boost::placeholders::_2), "Part_Sphere");
+ Gui::Application::Instance->commandManager().registerCallback(
+- boost::bind(&commandOverride, this, 3, true, _1, _2), "Part_Cone");
++ boost::bind(&commandOverride, this, 3, true, boost::placeholders::_1, boost::placeholders::_2), "Part_Cone");
+ Gui::Application::Instance->commandManager().registerCallback(
+- boost::bind(&commandOverride, this, 5, true, _1, _2), "Part_Torus");
++ boost::bind(&commandOverride, this, 5, true, boost::placeholders::_1, boost::placeholders::_2), "Part_Torus");
+ }
+
+ void CmdPrimtiveCompSubtractive::activated(int iMsg)
diff --git a/patch_std_gnupp14.patch b/patch_std_gnupp14.patch
new file mode 100644
index 000000000000..99a7d80d30a1
--- /dev/null
+++ b/patch_std_gnupp14.patch
@@ -0,0 +1,15 @@
+diff --git a/cMake/FreeCAD_Helpers/CompilerChecksAndSetups.cmake b/cMake/FreeCAD_Helpers/CompilerChecksAndSetups.cmake
+index 55370ed883..f74c845ce1 100644
+--- a/cMake/FreeCAD_Helpers/CompilerChecksAndSetups.cmake
++++ b/cMake/FreeCAD_Helpers/CompilerChecksAndSetups.cmake
+@@ -30,9 +30,8 @@ macro(CompilerChecksAndSetups)
+
+ # Enabled C++11 for Freecad 0.17 and later
+ if (FREECAD_VERSION VERSION_GREATER 0.16)
+- set(BUILD_ENABLE_CXX_STD "C++11" CACHE STRING "Enable C++ standard")
++ set(BUILD_ENABLE_CXX_STD "C++14" CACHE STRING "Enable C++ standard")
+ set_property(CACHE BUILD_ENABLE_CXX_STD PROPERTY STRINGS
+- "C++11"
+ "C++14"
+ "C++17"
+ "C++20"