summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2012-12-03 08:41:29 -0800
committerMike Swanson2012-12-03 08:41:29 -0800
commit5d94e81a1328402e96a9c69232e256be658f13b9 (patch)
treef445f642702f1a3587dd42a5d433acafd106d298
downloadaur-5d94e81a1328402e96a9c69232e256be658f13b9.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD28
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e438aee973c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = doschk
+ pkgdesc = Checks filenames for compatibility with SYSV and MS-DOS limits.
+ pkgver = 1.1
+ pkgrel = 1
+ url = http://www.gnu.org/software/doschk/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = http://ftp.debian.org/debian/pool/main/d/doschk/doschk_1.1.orig.tar.gz
+ source = http://ftp.debian.org/debian/pool/main/d/doschk/doschk_1.1-6.diff.gz
+ sha256sums = ea29748a48a3d8433a2f29059e3a760354a13e01d7a3f00237c5bd9e980c9f38
+ sha256sums = eecf830955648af177cb1772251a14d3725001c59bea627b7f319c1d4e04a41f
+
+pkgname = doschk
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..665307854be8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.pkg.tar*
+*.src.tar*
+*.gz
+src
+pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..593f3e4e50ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
+
+pkgname=doschk
+pkgver=1.1
+_debianpatch=6
+pkgrel=1
+pkgdesc="Checks filenames for compatibility with SYSV and MS-DOS limits."
+arch=('i686' 'x86_64')
+url="http://www.gnu.org/software/${pkgname}/"
+license=('GPL')
+depends=()
+source=(http://ftp.debian.org/debian/pool/main/d/${pkgname}/${pkgname}_${pkgver}.orig.tar.gz
+ http://ftp.debian.org/debian/pool/main/d/${pkgname}/${pkgname}_${pkgver}-${_debianpatch}.diff.gz)
+sha256sums=(ea29748a48a3d8433a2f29059e3a760354a13e01d7a3f00237c5bd9e980c9f38
+ eecf830955648af177cb1772251a14d3725001c59bea627b7f319c1d4e04a41f)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver.orig"
+ patch -p1 < "$srcdir"/${pkgname}_${pkgver}-${_debianpatch}.diff
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver.orig"
+ make DESTDIR="$pkgdir/" install
+ install -D -m 644 doschk.1 "$pkgdir"/usr/share/man/man1/doschk.1
+}