summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCork2020-04-21 20:15:55 +0200
committerCork2020-04-21 20:15:55 +0200
commit5dbff4c5f9554bc1bfc61b09d0f946ce7e392853 (patch)
tree66f2491c5ed84f4a7bb6b68342a6153c527c2085
parentb9c0fa15001d87a6dee756b7198f938cfe6838e8 (diff)
downloadaur-5dbff4c5f9554bc1bfc61b09d0f946ce7e392853.tar.gz
Realign default-to-fast-bios.patch with control.h
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD4
-rw-r--r--default-to-fast-bios.patch22
3 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d35d0251eee..11a1200109b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dosbox-x-fast-bios-git
pkgdesc = x86 emulator with builtin DOS, with patches with more features, with fastbios on by default
- pkgver = 7601.1adf084f2
+ pkgver = 9792.c9d907301
pkgrel = 1
url = http://dosbox.sourceforge.net
arch = i686
@@ -14,12 +14,13 @@ pkgbase = dosbox-x-fast-bios-git
depends = libxrandr
depends = mesa
depends = ffmpeg
+ conflicts = dosbox-x-git
source = dosbox-x::git://github.com/joncampbell123/dosbox-x.git
source = default-to-fast-bios.patch
source = dosbox-x.png
source = dosbox-x.desktop
md5sums = SKIP
- md5sums = aa3c4f3ce625e7a2d523ccfe77478a89
+ md5sums = 72303aba7f3d1ad98f81910124350f44
md5sums = 3dcfe45c5ed0433316eaea51e3620b36
md5sums = 615228a51b52d4788c73940602f1dc97
diff --git a/PKGBUILD b/PKGBUILD
index 2e79bbaca165..0aa8c8083152 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Mantainer: Cork
pkgname=dosbox-x-fast-bios-git
-pkgver=7601.1adf084f2
+pkgver=9792.c9d907301
pkgrel=1
pkgdesc="x86 emulator with builtin DOS, with patches with more features, with fastbios on by default"
arch=(i686 x86_64)
@@ -38,6 +38,6 @@ package() {
}
md5sums=('SKIP'
- 'aa3c4f3ce625e7a2d523ccfe77478a89'
+ '72303aba7f3d1ad98f81910124350f44'
'3dcfe45c5ed0433316eaea51e3620b36'
'615228a51b52d4788c73940602f1dc97')
diff --git a/default-to-fast-bios.patch b/default-to-fast-bios.patch
index 065ef4042928..4f96e6951b72 100644
--- a/default-to-fast-bios.patch
+++ b/default-to-fast-bios.patch
@@ -1,30 +1,30 @@
diff --git a/include/control.h b/include/control.h
-index f7d839a04..e341f9b8c 100644
+index 398b8ad15..c3ddf2eae 100644
--- a/include/control.h
+++ b/include/control.h
-@@ -91,7 +91,7 @@ public:
- opt_erasemapper = false;
- opt_resetmapper = false;
- opt_startmapper = false;
+@@ -93,7 +93,7 @@ public:
+ opt_erasemapper = false;
+ opt_resetmapper = false;
+ opt_startmapper = false;
- opt_fastbioslogo = false;
+ opt_fastbioslogo = true;
opt_alt_vga_render = false;
opt_date_host_forced = false;
- opt_disable_numlock_check = false;
+ opt_disable_numlock_check = false;
diff --git a/src/gui/sdlmain.cpp b/src/gui/sdlmain.cpp
-index 9ab978397..8291852f2 100644
+index 8d1476320..e7a41d8a4 100644
--- a/src/gui/sdlmain.cpp
+++ b/src/gui/sdlmain.cpp
-@@ -5885,7 +5885,7 @@ bool DOSBOX_parse_argv() {
+@@ -6258,7 +6258,7 @@ bool DOSBOX_parse_argv() {
fprintf(stderr," Make sure to surround the command in quotes to cover spaces.\n");
fprintf(stderr," -break-start Break into debugger at startup\n");
fprintf(stderr," -time-limit <n> Kill the emulator after 'n' seconds\n");
- fprintf(stderr," -fastbioslogo Fast BIOS logo (skip 1-second pause)\n");
+ fprintf(stderr," -bioslogo Show BIOS logo (1-second pause)\n");
fprintf(stderr," -log-con Log CON output to a log file\n");
-
- #if defined(WIN32)
-@@ -5957,8 +5957,8 @@ bool DOSBOX_parse_argv() {
+ fprintf(stderr," -log-int21 Log calls to INT 21h (debug level)\n");
+ fprintf(stderr," -log-fileio Log file I/O through INT 21h (debug level)\n");
+@@ -6332,8 +6332,8 @@ bool DOSBOX_parse_argv() {
else if (optname == "lang") {
if (!control->cmdline->NextOptArgv(control->opt_lang)) return false;
}