summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 15:57:05 +0200
committerM0Rf302015-06-17 15:57:05 +0200
commit5dec51ec0b6a5f799a1870b32af066a961427141 (patch)
tree41d796cc12598a8a2c400fb15c833b7ebf3bc67a
downloadaur-5dec51ec0b6a5f799a1870b32af066a961427141.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
-rw-r--r--loggerhead.install24
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2973d7ee93e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = loggerhead
+ pkgdesc = A web viewer for projects in bazaar.
+ pkgver = 1.18.1
+ pkgrel = 3
+ url = https://launchpad.net/loggerhead
+ install = loggerhead.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = python
+ depends = python2-simpletal
+ depends = python2-paste>=1.2
+ optdepends = python-paste-deploy: needed when proxying through Apache
+ source = http://launchpad.net/loggerhead/1.18/1.18.1/+download/loggerhead-1.18.1.tar.gz
+ md5sums = bef897d4674967ef835d1183d587d34f
+
+pkgname = loggerhead
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..184d819b2c6f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: M0Rf30
+# Contributor: Alper KANAT <alperkanat@raptiye.org>
+
+pkgname=loggerhead
+pkgver=1.18.1
+pkgrel=3
+pkgdesc="A web viewer for projects in bazaar."
+arch=('i686' 'x86_64')
+url="https://launchpad.net/loggerhead"
+license=('GPL2')
+depends=("python2-simpletal" "python2-paste>=1.2")
+makedepends=("python")
+optdepends=("python-paste-deploy: needed when proxying through Apache")
+source=(http://launchpad.net/loggerhead/1.18/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz)
+install=${pkgname}.install
+
+package() {
+ _LICENSE_DIR="$pkgdir/usr/share/licenses/$pkgname"
+ _DOC_DIR="$pkgdir/usr/share/doc/$pkgname"
+
+ cd ${srcdir}/$pkgname-$pkgver
+ python2 setup.py install --root=${pkgdir}
+
+ # copying license file
+ mkdir -p $_LICENSE_DIR
+ install -m644 COPYING.txt $_LICENSE_DIR
+
+ # copying readme file
+ mkdir -p $_DOC_DIR
+ install -m644 README $_DOC_DIR
+}
+
+md5sums=('bef897d4674967ef835d1183d587d34f')
diff --git a/loggerhead.install b/loggerhead.install
new file mode 100644
index 000000000000..66776d90f3f9
--- /dev/null
+++ b/loggerhead.install
@@ -0,0 +1,24 @@
+post_install() {
+ echo ""
+ echo "You can now simply run the 'serve-branches' with the branch you want to"
+ echo "serve on the command line:"
+ echo ""
+ echo " ./serve-branches ~/path/to/branch"
+ echo ""
+ echo "The script listens on port 8080 so head to http://localhost:8080/ in"
+ echo "your browser to see the branch. You can also pass a directory that"
+ echo "contains branches to the script, and it will serve a very simple"
+ echo "directory listing at other pages."
+ echo ""
+ echo "Consult to /usr/share/doc/loggerhead/README.txt for further information."
+ echo ""
+}
+
+post_upgrade() {
+ post_install
+}
+
+op=$1
+shift
+
+$op $*