aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Jung2022-06-25 16:54:35 +0200
committerPeter Jung2022-06-25 16:54:35 +0200
commit5e130a141f67053cb476bb81a49dddd30e5a7bf9 (patch)
treea0ce28355ae5eda2977f4cd74e898778717be16e
parentcdbce5d46ceaee0ea241f19493ac3c227b8e9874 (diff)
downloadaur-5e130a141f67053cb476bb81a49dddd30e5a7bf9.tar.gz
lld,mold fix
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
-rw-r--r--lld.sh.in2
-rw-r--r--mold.sh.in4
4 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3de1ca96f47b..d20e4f3a9bbf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = makepkg-optimize-mold
pkgdesc = Supplemental build and packaging optimizations for makepkg
pkgver = 28
- pkgrel = 1
+ pkgrel = 2
url = https://wiki.archlinux.org/index.php/Makepkg-optimize
arch = any
license = GPL
@@ -13,9 +13,8 @@ pkgbase = makepkg-optimize-mold
optdepends = polly: Polyhedral model optimization for clang
optdepends = mold: a modern fast linker
optdepends = lld: the clang linker
- optdepends = llvm-bolt: use yourself bolted toolchain for compiling
optdepends = aocc: use amd's llvm compiler for compiling
- optdepends = aocl: use amd's compiler libary for compiling
+ optdepends = aocl-aocc: use amd's compiler libary for compiling
optdepends = buildcache: a alternative to ccache
backup = etc/makepkg-optimize.conf
source = pgo.sh.in
@@ -47,10 +46,10 @@ pkgbase = makepkg-optimize-mold
sha1sums = 1acc26a5a5737804f5aa6cca9d4bbce733e0f429
sha1sums = 7556b8a8faff5b943efa5058ce9d8e325c4d35a6
sha1sums = d4e8f5ec1c30ebd69cce5121ea7823e1b42c3d27
- sha1sums = 64ec144a5e6d87c231601c386bf615db8ec36f52
+ sha1sums = eff21a001ae20ea6c06aba4c82e6a8e79711acb2
sha1sums = f8387e71a8807296fc24824eb16a3e53c7bc9f8a
sha1sums = 2374539e56aeed165cc15e790e17fe841fa0970d
- sha1sums = 06dd363ba4b32811971db823ff4b1cc26f8791bc
+ sha1sums = ab510f1789a9bcd1352706f13f6a0bb662d25831
sha1sums = 28b5ce40ba54198e715d79d97adaa54b67c2c7e5
sha1sums = e9bcb9d89b5a28bab77d0f20c9a19b5487acd89a
sha1sums = 0f2302c79ac2a05ea5628de0d8b36afbf43684b3
diff --git a/PKGBUILD b/PKGBUILD
index b770f9f636ce..eeb9069942c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=makepkg-optimize-mold
pkgver=28
-pkgrel=1
+pkgrel=2
pkgdesc='Supplemental build and packaging optimizations for makepkg'
arch=('any')
license=('GPL')
@@ -17,10 +17,9 @@ optdepends=("upx: Compress executables"
"polly: Polyhedral model optimization for clang"
"mold: a modern fast linker"
"lld: the clang linker"
- "llvm-bolt: use yourself bolted toolchain for compiling"
"aocc: use amd's llvm compiler for compiling"
- "aocl: use amd's compiler libary for compiling"
-"buildcache: a alternative to ccache")
+ "aocl-aocc: use amd's compiler libary for compiling"
+ "buildcache: a alternative to ccache")
backup=(etc/makepkg-optimize.conf)
_buildenv=({pgo,graphite,rice,mold,bolt,buildcache,lld,aocc,relocs,relocsgcc}.sh.in)
_executable=({upx,optipng,svgo}-exec.sh.in)
@@ -33,10 +32,10 @@ ${_conf[@]})
sha1sums=('1acc26a5a5737804f5aa6cca9d4bbce733e0f429'
'7556b8a8faff5b943efa5058ce9d8e325c4d35a6'
'd4e8f5ec1c30ebd69cce5121ea7823e1b42c3d27'
- '64ec144a5e6d87c231601c386bf615db8ec36f52'
+ 'eff21a001ae20ea6c06aba4c82e6a8e79711acb2'
'f8387e71a8807296fc24824eb16a3e53c7bc9f8a'
'2374539e56aeed165cc15e790e17fe841fa0970d'
- '06dd363ba4b32811971db823ff4b1cc26f8791bc'
+ 'ab510f1789a9bcd1352706f13f6a0bb662d25831'
'28b5ce40ba54198e715d79d97adaa54b67c2c7e5'
'e9bcb9d89b5a28bab77d0f20c9a19b5487acd89a'
'0f2302c79ac2a05ea5628de0d8b36afbf43684b3'
diff --git a/lld.sh.in b/lld.sh.in
index 1912ecec22ff..77ecd8823b11 100644
--- a/lld.sh.in
+++ b/lld.sh.in
@@ -16,6 +16,6 @@ buildenv_functions+=('buildenv_lld')
buildenv_lld() {
if
check_buildoption "lld" "y"; then
- LDFLAGS+="${LDFLAGS} -fuse-ld=lld"
+ LDFLAGS+=",-fuse-ld=lld"
fi
}
diff --git a/mold.sh.in b/mold.sh.in
index 49ded956bceb..5b7042995179 100644
--- a/mold.sh.in
+++ b/mold.sh.in
@@ -15,7 +15,7 @@ buildenv_functions+=('buildenv_mold')
buildenv_mold() {
if
- check_buildoption "mold" "y"; then
- LDFLAGS+="${LDFLAGS} -fuse-ld=mold"
+ check_buildoption "mold" "y"; then;
+ LDFLAGS+=",-fuse-ld=mold"
fi
}