summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbertabus2017-11-10 16:19:56 -0700
committerbertabus2017-11-10 16:19:56 -0700
commit5e4ea9a133cdbdbd4f30ee70f4ded210b6f398df (patch)
tree6a5e192b5b09776594008cf2e037c4acc019b21c
parent1940fc72af1318ba48492663e874646fe7d3f00e (diff)
downloadaur-5e4ea9a133cdbdbd4f30ee70f4ded210b6f398df.tar.gz
added desktop entry
-rw-r--r--PKGBUILD41
1 files changed, 37 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f5aa8df2aacc..fb97244ca2f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,12 +25,14 @@ changelog=
source=(http://www.geometricalgebra.net/downloads/${_rpkgname}-$pkgver.tar.gz
http://www.geometricalgebra.net/downloads/figures.zip
http://www.geometricalgebra.net/downloads/gaviewer.pdf
- http://www.geometricalgebra.net/downloads/gaviewerexercises.pdf)
+ http://www.geometricalgebra.net/downloads/gaviewerexercises.pdf
+ http://www.geometricalgebra.net/backgrounds/crossproduct.png)
noextract=()
md5sums=('ce5285dfa74db56a4ba7577a1a5e6738'
'172fc88d38e3b29960e33788a1a4f045'
'43fd8ca7da3e0cac3fee2350d05c9d3e'
- '60543f7f310292e9c70e9d98dd095c9e')
+ '60543f7f310292e9c70e9d98dd095c9e'
+ '7877ec738b081ee4c1fc450be19242fe')
build() {
cd "$srcdir/${_rpkgname}-$pkgver"
@@ -46,6 +48,37 @@ package() {
"$pkgdir/usr/share/doc/$pkgname/"
chmod -x $srcdir/Figures/*
cp -r $srcdir/Figures "$pkgdir/usr/share/doc/$pkgname/Figures"
-}
+ mkdir -p "$pkgdir/usr/share/pixmaps/$pkgname"
+ cp $srcdir/crossproduct.png "$pkgdir/usr/share/pixmaps/$pkgname/"
+ echo"[Desktop Entry]
-# vim:set ts=2 sw=2 et: \ No newline at end of file
+ # The type as listed above
+ Type=Application
+
+ # The version of the desktop entry specification to which this file complies
+ Version=0.86
+
+ # The name of the application
+ Name=gaviewer
+
+ # A comment which can/will be used as a tooltip
+ Comment=Geometric algebra viewer and experimenter
+
+ # The path to the folder in which the executable is run
+ Path=/usr/bin/gaviewer
+
+ # The executable of the application, possibly with arguments.
+ Exec=gaviewer
+
+ # The name of the icon that will be used to display this entry
+ Icon=/home/bertabus/Desktop/gaviewerICO.ico
+
+ # Describes whether this application needs to be run in a terminal or not
+ Terminal=false
+
+ # Describes the categories in which this entry should be shown
+ Categories=Education;Math;
+ StartupNotify=false" > "$pkgdir/usr/share/applications/${pkgname}.desktop"
+ }
+
+ # vim:set ts=2 sw=2 et: \ No newline at end of file