summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2016-02-02 21:41:25 +0100
committerGordian Edenhofer2016-02-02 23:20:07 +0100
commit5e69e2d349ab41abf0ecfdc682a6980c1d89d33d (patch)
tree175a5481fa2fb5596f3d0a9f2c38c91f43686556
parent1abdf7ffdab930d288b7c38409ad56a269ab918b (diff)
downloadaur-5e69e2d349ab41abf0ecfdc682a6980c1d89d33d.tar.gz
Upgpkg: 2.2.4-1
Completely redesign the package on top of the patched debian source package. Therefore removing the need for manual patching. Mimic the Makefile install operation since it broken in a lot of ways. Add glibc and bash to the dependency array. Update the URL to the debian package inspection URL.
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD51
-rwxr-xr-xef.sh17
-rw-r--r--ef.sh.patch11
-rw-r--r--efence.c.patch12
-rw-r--r--eftest.c.patch18
-rw-r--r--page.c.patch29
-rw-r--r--print.c.patch11
8 files changed, 50 insertions, 127 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 870ba42b5c3b..e50e7ead604d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Feb 2 22:20:06 UTC 2016
pkgbase = electricfence
- pkgdesc = Debugging malloc() that uses the VM hardware to detect buffer overruns
- pkgver = 2.2.2
- pkgrel = 3
- url = http://perens.com/FreeSoftware/ElectricFence/
+ pkgdesc = A malloc(3) debugger that uses virtual memory hardware to detect illegal memory accesses.
+ pkgver = 2.2.4
+ pkgrel = 1
+ url = https://packages.debian.org/sid/electric-fence
arch = i686
arch = x86_64
license = GPL2
- source = http://dl.packetstormsecurity.net/programming-tutorials/ElectricFence-2.2.2.tar.gz
- source = ef.sh.patch
- source = efence.c.patch
- source = eftest.c.patch
- source = page.c.patch
- source = print.c.patch
- md5sums = 56a3cbfdbf65f916988787c789c63e80
- md5sums = 3d5905c3cc9c52f09b6a387520a0d86c
- md5sums = 67023a6cdcae4058e698089b041d00a8
- md5sums = 3aad193fdc0b282d5d5fb05bb06ba4f9
- md5sums = 4b5292775e9588b21ccf867f0160a34d
- md5sums = 5026c7863d3b980ff093cb2d22c2d303
+ depends = glibc
+ depends = bash
+ source = http://archive.ubuntu.com/ubuntu/pool/universe/e/electric-fence/electric-fence_2.2.4.tar.gz
+ source = ef.sh
+ md5sums = 78197d625452a9bc2d171e47bce0ddff
+ md5sums = 215c183e71fa6f8d40cbd2fe65c860c9
pkgname = electricfence
diff --git a/PKGBUILD b/PKGBUILD
index 700b58cb7446..d025ef879a03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,31 @@
+# Maintainer: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de>
# Contributor: Jonathan Liu <net147@gmail.com>
+
pkgname=electricfence
-pkgver=2.2.2
-pkgrel=3
-pkgdesc="Debugging malloc() that uses the VM hardware to detect buffer overruns"
+pkgver=2.2.4
+pkgrel=1
+pkgdesc="A malloc(3) debugger that uses virtual memory hardware to detect illegal memory accesses."
arch=('i686' 'x86_64')
-url="http://perens.com/FreeSoftware/ElectricFence/"
license=('GPL2')
-source=("http://dl.packetstormsecurity.net/programming-tutorials/ElectricFence-${pkgver}.tar.gz"
- "ef.sh.patch"
- "efence.c.patch"
- "eftest.c.patch"
- "page.c.patch"
- "print.c.patch")
-md5sums=('56a3cbfdbf65f916988787c789c63e80'
- '3d5905c3cc9c52f09b6a387520a0d86c'
- '67023a6cdcae4058e698089b041d00a8'
- '3aad193fdc0b282d5d5fb05bb06ba4f9'
- '4b5292775e9588b21ccf867f0160a34d'
- '5026c7863d3b980ff093cb2d22c2d303')
+url="https://packages.debian.org/sid/electric-fence"
+depends=('glibc' 'bash')
+source+=("http://archive.ubuntu.com/ubuntu/pool/universe/e/electric-fence/electric-fence_${pkgver}.tar.gz"
+ "ef.sh")
+md5sums=('78197d625452a9bc2d171e47bce0ddff'
+ '215c183e71fa6f8d40cbd2fe65c860c9')
build() {
- cd "${srcdir}/ElectricFence-${pkgver}"
- patch -Np0 -i "$startdir/src/ef.sh.patch"
- patch -Np0 -i "$startdir/src/efence.c.patch"
- patch -Np0 -i "$startdir/src/eftest.c.patch"
- patch -Np0 -i "$startdir/src/page.c.patch"
- patch -Np0 -i "$startdir/src/print.c.patch"
- make
+ make -C "${srcdir}/electric-fence-2.2.3"
}
package() {
- cd "${srcdir}/ElectricFence-${pkgver}"
- install -d -m 755 "${pkgdir}/usr/bin"
- install -d -m 755 "${pkgdir}/usr/lib"
- install -d -m 755 "${pkgdir}/usr/man/man3"
- make install prefix="${pkgdir}/usr" install
-}
+ cd "${srcdir}/electric-fence-2.2.3"
-# vim:set ts=2 sw=2 et:
+ # Mimic the Makefile since it is pretty broken
+ install -D -m755 ../ef.sh "${pkgdir}"/usr/bin/ef
+ install -D -m644 libefence.a "${pkgdir}"/usr/lib/libefence.a
+ install -D -m755 libefence.so.0.0 "${pkgdir}"/usr/lib/libefence.so.0.0
+ ln -s libefence.so.0.0 "${pkgdir}"/usr/lib/libefence.so.0
+ ln -s libefence.so.0.0 "${pkgdir}"/usr/lib/libefence.so
+ install -D -m644 libefence.3 "${pkgdir}"/usr/man/man3/libefence.3
+}
diff --git a/ef.sh b/ef.sh
new file mode 100755
index 000000000000..ba1c46f94d72
--- /dev/null
+++ b/ef.sh
@@ -0,0 +1,17 @@
+#!/bin/bash
+
+#
+# Simple script to run electric fence on stuff. (needs libefence.so).
+#
+# $Id: ef,v 1.1 1999/03/31 21:31:23 kefka Exp $
+#
+
+# Usage check.
+if [ "$1" = "" ]; then
+ echo "$0: Usage: ef [executable] [arguments]."
+ echo " Runs the executable under the Electric Fence malloc debugger."
+ exit
+fi
+
+# Set the environment to load eletric fence.
+LD_PRELOAD=libefence.so.0.0 exec "$@"
diff --git a/ef.sh.patch b/ef.sh.patch
deleted file mode 100644
index 9ee382ac587e..000000000000
--- a/ef.sh.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ef.sh.orig 1999-04-12 09:59:22.000000000 +1000
-+++ ef.sh 2008-02-18 17:00:03.000000000 +1100
-@@ -15,6 +15,6 @@
-
- # Set the environment to load eletric fence.
- (\
--export LD_PRELOAD=libefence.so.0.0;\
--exec $*;\
-+export LD_PRELOAD=libefence.so.0;\
-+exec "$@";\
- )
diff --git a/efence.c.patch b/efence.c.patch
deleted file mode 100644
index e59ccc473d8f..000000000000
--- a/efence.c.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- efence.c.orig 1999-04-13 11:00:49.000000000 +1000
-+++ efence.c 2008-02-18 17:01:45.000000000 +1100
-@@ -271,7 +271,9 @@
- char * string;
- Slot * slot;
-
-+#if 0
- EF_Print(version);
-+#endif
-
- #ifdef USE_SEMAPHORE
- if (sem_init(&EF_sem, 0, 1) >= 0) {
diff --git a/eftest.c.patch b/eftest.c.patch
deleted file mode 100644
index f638e7afa379..000000000000
--- a/eftest.c.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- eftest.c.orig 1995-01-20 15:54:30.000000000 +1100
-+++ eftest.c 2008-02-18 17:05:29.000000000 +1100
-@@ -40,13 +40,13 @@
- )
- {
- signal(PAGE_PROTECTION_VIOLATED_SIGNAL, SIG_DFL);
-- longjmp(env, 1);
-+ siglongjmp(env, 1);
- }
-
- static int
- gotSegmentationFault(int (*test)(void))
- {
-- if ( setjmp(env) == 0 ) {
-+ if ( sigsetjmp(env, 1) == 0 ) {
- int status;
-
- signal(PAGE_PROTECTION_VIOLATED_SIGNAL
diff --git a/page.c.patch b/page.c.patch
deleted file mode 100644
index d7740ec5e56e..000000000000
--- a/page.c.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- page.c.orig 1999-04-12 07:45:26.000000000 +1000
-+++ page.c 2008-02-18 17:03:21.000000000 +1100
-@@ -31,7 +31,7 @@
-
- #if ( !defined(sgi) && !defined(_AIX) &&!defined(__USE_BSD))
- extern int sys_nerr;
--extern char * sys_errlist[];
-+extern const char *const sys_errlist[];
- #endif
-
- static const char *
-@@ -70,7 +70,7 @@
- */
- allocation = (caddr_t) mmap(
- startAddr
-- ,(int)size
-+ ,size
- ,PROT_READ|PROT_WRITE
- ,MAP_PRIVATE|MAP_ANONYMOUS
- ,-1
-@@ -122,7 +122,7 @@
- */
- allocation = (caddr_t) mmap(
- startAddr
-- ,(int)size
-+ ,size
- ,PROT_READ|PROT_WRITE
- ,MAP_PRIVATE
- ,devZeroFd
diff --git a/print.c.patch b/print.c.patch
deleted file mode 100644
index 7797d8ee37a2..000000000000
--- a/print.c.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- print.c.orig 1999-04-12 09:29:21.000000000 +1000
-+++ print.c 2008-02-18 17:04:24.000000000 +1100
-@@ -111,7 +111,7 @@
- break;
- case 'c':
- {
-- char c = va_arg(args, char);
-+ char c = va_arg(args, int);
-
- (void) write(2, &c, 1);
- }