summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevgfilim12019-11-22 17:16:27 +0500
committerevgfilim12019-11-22 17:16:27 +0500
commit5e6acd309a9e8e372f0e0f324d56b7567d040429 (patch)
tree4527973b0aded87421a25eb2b3e17501f92cbe50
parent75dd2d24555dcd3c2bfd454f1e133dc0eaf9dc9f (diff)
downloadaur-5e6acd309a9e8e372f0e0f324d56b7567d040429.tar.gz
New version: v2.4
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b30b37a513f5..e70438e2fb20 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-aiogram
pkgdesc = A pretty simple and fully asynchronous library for Telegram Bot API written in Python 3.7 with asyncio and aiohttp
- pkgver = 2.3
+ pkgver = 2.4
pkgrel = 1
url = https://github.com/aiogram/aiogram
arch = any
@@ -8,6 +8,7 @@ pkgbase = python-aiogram
makedepends = python-setuptools
depends = python>=3.7
depends = python-aiohttp>=3.5.4
+ depends = python-aiohttp<4.0.0
depends = python-babel>=2.6.0
depends = python-certifi>=2019.3.9
optdepends = python-uvloop: fast, drop-in replacement of the built-in asyncio event loop
@@ -16,9 +17,9 @@ pkgbase = python-aiogram
optdepends = python-emoji: emojize and demojize support
optdepends = python-aioredis: Redis storage support
optdepends = python-aiohttp-socks: SOCKS4(a) and SOCKS5 proxy support
- source = https://github.com/aiogram/aiogram/archive/v2.3.tar.gz
+ source = https://github.com/aiogram/aiogram/archive/v2.4.tar.gz
source = no-pip.patch
- sha256sums = 20f509db24fdd54c700e54c9400c40cdf9ccce42716b690436787d1df8a14057
+ sha256sums = ddaf49d6f1c38d597102eadd280c77ad26b451e4606464a72f42d43e227ae7e7
sha256sums = 6279e16e20acbae3e289cd0e5ba89db199753f35afa5201e3e8adbcd9c1653bb
pkgname = python-aiogram
diff --git a/PKGBUILD b/PKGBUILD
index 36699fd96b92..eedf4ee9e6df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Evgeniy Filimonov <evgfilim1@gmail.com>
pkgname='python-aiogram'
-pkgver=2.3
+pkgver=2.4
pkgrel=1
pkgdesc="A pretty simple and fully asynchronous library for Telegram Bot API written in Python 3.7 with asyncio and aiohttp"
arch=('any')
url="https://github.com/aiogram/aiogram"
license=('MIT')
-depends=('python>=3.7' 'python-aiohttp>=3.5.4' 'python-babel>=2.6.0' 'python-certifi>=2019.3.9')
+depends=('python>=3.7' 'python-aiohttp>=3.5.4' 'python-aiohttp<4.0.0' 'python-babel>=2.6.0' 'python-certifi>=2019.3.9')
makedepends=(
'python-setuptools'
# 'python-pip'
@@ -23,7 +23,7 @@ optdepends=(
)
source=("https://github.com/aiogram/aiogram/archive/v${pkgver}.tar.gz"
"no-pip.patch")
-sha256sums=('20f509db24fdd54c700e54c9400c40cdf9ccce42716b690436787d1df8a14057'
+sha256sums=('ddaf49d6f1c38d597102eadd280c77ad26b451e4606464a72f42d43e227ae7e7'
'6279e16e20acbae3e289cd0e5ba89db199753f35afa5201e3e8adbcd9c1653bb')
prepare() {