summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122016-08-30 10:41:11 +0200
committerwillemw122016-08-30 10:41:11 +0200
commit5e8a960c17206ee48ba1bc95534e44a89d1592b5 (patch)
treec287949d96c4746806023c9cec024506e3c99c29
downloadaur-5e8a960c17206ee48ba1bc95534e44a89d1592b5.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD33
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..068b0370ade9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = tv-overlord-git
+ pkgdesc = Download and manage tv shows
+ pkgver = r335.d7b247f
+ pkgrel = 1
+ url = https://github.com/8cylinder/tv-overlord
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python-beautifulsoup4
+ depends = python-click
+ depends = python-colorama
+ depends = python-dateutil
+ depends = python-feedparser
+ depends = python-tvdb_api-git
+ depends = python-requests
+ optdepends = deluge: torrent client
+ optdepends = transmission-cli: torrent client
+ source = tv-overlord::git://github.com/8cylinder/tv-overlord.git
+ md5sums = SKIP
+
+pkgname = tv-overlord-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2add4c61736f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: willemw <willemw12@gmail.com>
+
+_pkgname=tv-overlord
+pkgname=$_pkgname-git
+pkgver=r335.d7b247f
+pkgrel=1
+pkgdesc="Download and manage tv shows"
+url="https://github.com/8cylinder/tv-overlord"
+license=('GPL')
+arch=('any')
+depends=('python-beautifulsoup4' 'python-click' 'python-colorama' 'python-dateutil'
+ #'python-feedparser' 'python-tvdb_api' 'python-requests')
+ 'python-feedparser' 'python-tvdb_api-git' 'python-requests')
+makedepends=('git' 'python-setuptools')
+optdepends=('deluge: torrent client' 'transmission-cli: torrent client')
+source=($_pkgname::git://github.com/8cylinder/tv-overlord.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $_pkgname
+ python setup.py build
+}
+
+package() {
+ cd $_pkgname
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+