summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2020-01-09 12:41:18 -0500
committerGuillaume Horel2020-01-09 12:42:06 -0500
commit5e8f8fad52930c8b5102346255ae5e75ab37db5c (patch)
treec73d3f2d38c5a18a4cb86d7a7ccce5fac3ff10fe
parent1e07c37f9aaefb5046d983645f24a00dfc461862 (diff)
downloadaur-5e8f8fad52930c8b5102346255ae5e75ab37db5c.tar.gz
fix dependencies and url
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e2a861f8d54..285969262eeb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,10 +2,12 @@ pkgbase = python-fontmath
pkgdesc = A set of objects for performing math operations on font data.
pkgver = 0.5.2
pkgrel = 1
- url = https://github.com/typesupply/fontMath
+ url = https://github.com/robotools/fontMath
arch = any
license = MIT
checkdepends = python-pytest
+ checkdepends = python-pytest-runner
+ makedepends = python-setuptools
depends = python-fonttools
options = !emptydirs
source = https://pypi.org/packages/source/f/fontMath/fontMath-0.5.2.zip
diff --git a/PKGBUILD b/PKGBUILD
index 3ae444160b8d..36d4f36719db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,19 +6,19 @@ pkgver=0.5.2
pkgrel=1
pkgdesc='A set of objects for performing math operations on font data.'
arch=('any')
-url='https://github.com/typesupply/fontMath'
+url='https://github.com/robotools/fontMath'
license=('MIT')
-makedepends=()
+makedepends=('python-setuptools')
depends=('python-fonttools')
-checkdepends=('python-pytest')
+checkdepends=('python-pytest' 'python-pytest-runner')
options=(!emptydirs)
source=("https://pypi.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}.zip")
sha256sums=('9f7934f85859f057f8e6ff3fc2e80c1cd3ba8c9021e71a7794efdf74c6a49ce2')
package() {
-
cd "${srcdir}/$_pkgname-$pkgver"
python setup.py install --root=$pkgdir || return 1
+ install -D -m644 License.txt "${pkgdir}/usr/share/licenses/${pkgname}/License.txt"
}
check() {