summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-08-18 19:46:44 -0600
committerJohn D Jones III2015-08-18 19:46:44 -0600
commit5ebb0eccd8629ab98ee82e30c5c7f86cabef73b5 (patch)
treede3618491432ab9be4ced38e9a2ea0e70e51e21a
downloadaur-5ebb0eccd8629ab98ee82e30c5c7f86cabef73b5.tar.gz
Initial commit 0.19, no tests
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD48
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5245753a5765
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = perl-www-aur
+ pkgdesc = API for the Archlinux User Repository website.
+ pkgver = 0.19
+ pkgrel = 1
+ url = https://metacpan.org/release/WWW-AUR
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl-http-cookies
+ depends = perl-json
+ depends = perl-lwp-protocol-https>=6
+ depends = perl-uri
+ depends = perl-libwww
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/J/JU/JUSTER/WWW-AUR-0.19.tar.gz
+ md5sums = 0d7b378481e0eb28918d24419aeaa485
+ sha512sums = 50f3fd25413a88ec094f730f489a8f7b879bbc2ea49b3d39d83c52b5aaf2771300ae50eb40123112a2bd9a3fd867a57f304eab1f042391170fe92d281cb80f0c
+
+pkgname = perl-www-aur
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70f1da4fd463
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Contributor: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.30
+
+pkgname='perl-www-aur'
+pkgver='0.19'
+pkgrel='1'
+pkgdesc="API for the Archlinux User Repository website."
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-http-cookies' 'perl-json' 'perl-lwp-protocol-https>=6' 'perl-uri' 'perl-libwww')
+makedepends=()
+url='https://metacpan.org/release/WWW-AUR'
+source=('http://search.cpan.org/CPAN/authors/id/J/JU/JUSTER/WWW-AUR-0.19.tar.gz')
+md5sums=('0d7b378481e0eb28918d24419aeaa485')
+sha512sums=('50f3fd25413a88ec094f730f489a8f7b879bbc2ea49b3d39d83c52b5aaf2771300ae50eb40123112a2bd9a3fd867a57f304eab1f042391170fe92d281cb80f0c')
+_distdir="WWW-AUR-0.19"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: