summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-09-04 16:20:46 -0600
committerMark Wagie2021-09-04 16:20:46 -0600
commit5ebd23dfb95055b749d3b8f0be7846eafcfc8ecb (patch)
tree0d1589f43ff62f8fe4e23edca47a9ecac623ee6a
parent2d28bb8ff79022ddef088ad41ab7ac9da395964b (diff)
downloadaur-5ebd23dfb95055b749d3b8f0be7846eafcfc8ecb.tar.gz
0.2.4
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD68
2 files changed, 50 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b3313c3c3f8..a53c6e937b1d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = thiefmd
pkgdesc = The markdown editor worth stealing. Inspired by Ulysses, based on code from Quilter
- pkgver = 0.2.3
+ pkgver = 0.2.4
pkgrel = 1
url = https://thiefmd.com
arch = x86_64
@@ -9,23 +9,23 @@ pkgbase = thiefmd
makedepends = git
makedepends = meson
makedepends = vala
- depends = gtkspell3
- depends = webkit2gtk
+ depends = clutter
depends = discount
depends = gtksourceview4
+ depends = gtkspell3
depends = libarchive
- depends = clutter
depends = libgee
- depends = libhandy
depends = link-grammar
- source = git+https://github.com/kmwallio/ThiefMD.git#commit=5fc261ad2b68478ff11880c5134c9c3fca797c56
- source = git+https://github.com/ThiefMD/custom-gtksourceview-languages.git
+ depends = libhandy
+ depends = webkit2gtk
+ source = git+https://github.com/kmwallio/ThiefMD.git#tag=v0.2.4-easypdf
source = git+https://github.com/ThiefMD/BiBtex-vala.git
source = git+https://github.com/ThiefMD/ghost-vala.git
source = git+https://github.com/TwiRp/ultheme-vala.git
source = git+https://github.com/ThiefMD/wordpress-vala.git
source = git+https://github.com/ThiefMD/writeas-vala.git
source = git+https://github.com/ThiefMD/libwritegood-vala.git
+ source = git+https://github.com/ThiefMD/custom-gtksourceview-languages.git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f7f01f272a33..09f3c8c45127 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=thiefmd
-pkgver=0.2.3
-_codename=draftcheck
+pkgver=0.2.4
+_codename=easypdf
pkgrel=1
pkgdesc="The markdown editor worth stealing. Inspired by Ulysses, based on code from Quilter"
arch=('x86_64' 'aarch64')
url="https://thiefmd.com"
license=('GPL3')
-depends=('gtkspell3' 'webkit2gtk' 'discount' 'gtksourceview4' 'libarchive'
- 'clutter' 'libgee' 'libhandy' 'link-grammar')
+depends=('clutter' 'discount' 'gtksourceview4' 'gtkspell3' 'libarchive' 'libgee'
+ 'link-grammar' 'libhandy' 'webkit2gtk')
makedepends=('git' 'meson' 'vala')
-_commit=5fc261ad2b68478ff11880c5134c9c3fca797c56
-source=("git+https://github.com/kmwallio/ThiefMD.git#commit=$_commit"
- 'git+https://github.com/ThiefMD/custom-gtksourceview-languages.git'
+source=("git+https://github.com/kmwallio/ThiefMD.git#tag=v$pkgver-$_codename"
'git+https://github.com/ThiefMD/BiBtex-vala.git'
'git+https://github.com/ThiefMD/ghost-vala.git'
'git+https://github.com/TwiRp/ultheme-vala.git'
'git+https://github.com/ThiefMD/wordpress-vala.git'
'git+https://github.com/ThiefMD/writeas-vala.git'
- 'git+https://github.com/ThiefMD/libwritegood-vala.git')
+ 'git+https://github.com/ThiefMD/libwritegood-vala.git'
+ 'git+https://github.com/ThiefMD/custom-gtksourceview-languages.git')
sha256sums=('SKIP'
'SKIP'
'SKIP'
@@ -29,34 +28,53 @@ sha256sums=('SKIP'
'SKIP')
pkgver() {
- cd "$srcdir/ThiefMD"
- git describe --tags | sed "s/^v//;s/-$_codename//;s/-/+/g"
+ cd "$srcdir/ThiefMD"
+ git describe --tags | sed "s/^v//;s/-$_codename//;s/-/+/g"
}
prepare() {
- cd "$srcdir/ThiefMD"
- git submodule init
- for _submodule in BiBtex-vala ghost-vala ultheme-vala wordpress-vala writeas-vala libwritegood-vala; do
- git config submodule.src/${_submodule}.url $srcdir/${_submodule}
- done
-
- git submodule init data/language-specs
- git config submodule.custom-gtksourceview-languages.url $srcdir/custom-gtksourceview-languages
- git submodule update
+ cd "$srcdir/ThiefMD"
+ git submodule init src/bibtex
+ git config submodule.BiBtex-vala.url $srcdir/BiBtex-vala
+
+ git submodule init src/ghost
+ git config submodule.ghost-vala.url $srcdir/ghost-vala
+
+ git submodule init src/ultheme
+ git config submodule.ultheme-vala.url $srcdir/ultheme-vala
+
+ git submodule init src/wordpress
+ git config submodule.wordpress-vala.url $srcdir/wordpress-vala
+
+ git submodule init src/writeas
+ git config submodule.writeas-vala.url $srcdir/writeas-vala
+
+ git submodule init src/writegood
+ git config submodule.libwritegood-vala.url $srcdir/libwritegood-vala
+
+# git submodule init
+# for _submodule in ; do
+# git config submodule.src/${_submodule}.url $srcdir/${_submodule}
+# done
+
+ git submodule init data/language-specs
+ git config submodule.custom-gtksourceview-languages.url $srcdir/custom-gtksourceview-languages
+
+ git submodule update
}
build() {
- arch-meson ThiefMD build
- meson compile -C build
+ arch-meson ThiefMD build
+ meson compile -C build
}
-# No tests defined
+# Requires build_tests=true
#check() {
-# meson test -C build --print-errorlogs
+# meson test -C build --print-errorlogs
#}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ DESTDIR="$pkgdir" meson install -C build
- ln -s "/usr/bin/com.github.kmwallio.$pkgname" "$pkgdir/usr/bin/$pkgname"
+ ln -s "/usr/bin/com.github.kmwallio.$pkgname" "$pkgdir/usr/bin/$pkgname"
}