summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJack O'Sullivan2018-06-01 13:48:23 +0100
committerJack O'Sullivan2018-06-01 13:48:23 +0100
commit5ecaf29bd49d74024618d11494f8572ca011a78a (patch)
tree7ec39bfe49085fb190b4fb5486a1458e5049022e
downloadaur-5ecaf29bd49d74024618d11494f8572ca011a78a.tar.gz
Initial commit at upstream version 1.1.1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..efb2cf23452d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = terminal-mines
+ pkgdesc = An ncurses-based minesweeper game.
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://github.com/accatyyc/terminal-mines
+ arch = i686
+ arch = x86_64
+ license = custom:Unknown
+ source = git+https://github.com/accatyyc/terminal-mines#tag=1.1.1
+ sha256sums = SKIP
+
+pkgname = terminal-mines
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d16c5925e82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jack O'Sullivan <jackos1998 at gmail dot com>
+pkgname=terminal-mines
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="An ncurses-based minesweeper game."
+url='https://github.com/accatyyc/terminal-mines'
+license=("custom:Unknown")
+arch=('i686' 'x86_64')
+source=("git+https://github.com/accatyyc/terminal-mines#tag=$pkgver")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$pkgname"
+ git submodule init
+ git submodule update
+}
+build() {
+ cd "$pkgname"
+ make
+}
+package() {
+ cd "$pkgname"
+ make INSTALL_PATH="$pkgdir/usr" install
+}