summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoréclairevoyant2022-12-11 07:15:44 -0500
committeréclairevoyant2022-12-11 07:15:44 -0500
commit5ed139ad245777a31bf97ed622b1dc2423ea9048 (patch)
tree7f09f3ee21d83fea5b8b2974185fedb4a1b79d49
parentb6d7cb93b2f6233b7b265c7bec893a3a2b66c6bb (diff)
downloadaur-5ed139ad245777a31bf97ed622b1dc2423ea9048.tar.gz
ly: fix for file protocol submodules
fix backup, conflicts add .gitignore Signed-off-by: éclairevoyant <848000+eclairevoyant@users.noreply.github.com>
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD37
3 files changed, 33 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 026dc73270c6..bdefd6628c70 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = ly
pkgdesc = TUI display manager
pkgver = 0.5.3
- pkgrel = 0
- url = https://github.com/nullgemm/ly
+ pkgrel = 2
+ url = https://github.com/fairyglade/ly
arch = i686
arch = x86_64
arch = aarch64
@@ -10,19 +10,18 @@ pkgbase = ly
makedepends = git
depends = pam
depends = xorg-xauth
- conflicts = ly-git
- conflicts = python-ly-git
backup = etc/ly/config.ini
- source = git+https://github.com/nullgemm/ly.git#tag=v0.5.3
+ backup = etc/ly/wsetup.sh
+ backup = etc/ly/xsetup.sh
+ source = git+https://github.com/fairyglade/ly.git#tag=v0.5.3
source = git+https://github.com/nullgemm/argoat.git
source = git+https://github.com/nullgemm/configator.git
source = git+https://github.com/nullgemm/dragonfail.git
source = git+https://github.com/nullgemm/termbox_next.git
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
pkgname = ly
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 2cfa4170157f..9e2e21ef26db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,43 @@
-# Maintainer: nullgemm <nullgemm@mailbox.org>
+# Maintainer: éclairevoyant
+# Contributor: nullgemm <nullgemm@mailbox.org>
+
pkgname=ly
pkgver=0.5.3
-pkgrel=0
+pkgrel=2
pkgdesc="TUI display manager"
arch=('i686' 'x86_64' 'aarch64')
-url="https://github.com/nullgemm/ly"
+url="https://github.com/fairyglade/$pkgname"
license=('custom:WTFPL')
makedepends=('git')
depends=('pam' 'xorg-xauth')
-conflicts=('ly-git' 'python-ly-git')
-backup=('etc/ly/config.ini')
-source=("git+https://github.com/nullgemm/${pkgname}.git#tag=v${pkgver}"
+conflicts=('python-ly') # TODO prevent this
+backup=(etc/$pkgname/{config.ini,wsetup.sh,xsetup.sh})
+source=("git+$url.git#tag=v$pkgver"
"git+https://github.com/nullgemm/argoat.git"
"git+https://github.com/nullgemm/configator.git"
"git+https://github.com/nullgemm/dragonfail.git"
"git+https://github.com/nullgemm/termbox_next.git")
-sha256sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+b2sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
prepare() {
- cd "$srcdir/$pkgname"
+ cd $pkgname
git submodule init
for _i in argoat configator dragonfail termbox_next; do
- git config submodule.sub/${_i}.url $srcdir/${_i}
+ git config submodule.sub/$_i.url "$srcdir/$_i"
done
- git submodule update
+ git -c protocol.file.allow=always submodule update
}
build() {
- cd "$srcdir/$pkgname"
- make
+ make -C $pkgname
}
package() {
- cd "$srcdir/$pkgname"
+ cd $pkgname
make DESTDIR="$pkgdir" install
- install -Dm644 license.md "${pkgdir}/usr/share/licenses/${pkgname}/WTFPL"
+ install -Dm644 license.md "$pkgdir/usr/share/licenses/$pkgname/WTFPL"
}