summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2021-11-18 10:41:21 +0100
committerPhilipp A2021-11-18 10:41:21 +0100
commit5ed7f695ef20bdfb8a7f00b70604671aaf46d582 (patch)
tree1c60ab9f32b579dba5d7d2a9a41fdf5c027960e6
parentd5879dd056ae15d50ff88bbada59f9a07593c701 (diff)
downloadaur-5ed7f695ef20bdfb8a7f00b70604671aaf46d582.tar.gz
v0.7.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1821c0026314..037d580cd494 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = python-pytest-pycharm
pkgdesc = Plugin for pytest to enter PyCharm debugger on uncaught exceptions.
- pkgver = 0.6.0
+ pkgver = 0.7.0
pkgrel = 1
url = https://github.com/jlubcke/pytest-pycharm
arch = any
license = BSD
- makedepends = python-pip
depends = python
- noextract = pytest_pycharm-0.6.0-py3-none-any.whl
- source = https://files.pythonhosted.org/packages/py3/p/pytest-pycharm/pytest_pycharm-0.6.0-py3-none-any.whl
- sha256sums = 6d363c98a6f14ae27eb7a4f30be90946fb3c93003365ae18632161fc988de3a7
+ noextract = pytest_pycharm-0.7.0-py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py3/p/pytest-pycharm/pytest_pycharm-0.7.0-py3-none-any.whl
+ sha256sums = 5a642e3e21487cb2e1bf78464edb7f1b31996f8fce34780786f218144de9d7cf
pkgname = python-pytest-pycharm
-
diff --git a/PKGBUILD b/PKGBUILD
index 2c3f34ef0394..2ea5a14e9674 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,20 @@
_name=pytest-pycharm
pkgname=python-$_name
-pkgver=0.6.0
+pkgver=0.7.0
pkgrel=1
pkgdesc='Plugin for pytest to enter PyCharm debugger on uncaught exceptions.'
arch=(any)
url="https://github.com/jlubcke/$_name"
license=(BSD)
depends=(python)
-makedepends=(python-pip)
_wheel="${_name/-/_}-$pkgver-py3-none-any.whl"
source=("https://files.pythonhosted.org/packages/py3/${_name::1}/$_name/$_wheel")
-sha256sums=('6d363c98a6f14ae27eb7a4f30be90946fb3c93003365ae18632161fc988de3a7')
+sha256sums=('5a642e3e21487cb2e1bf78464edb7f1b31996f8fce34780786f218144de9d7cf')
noextract=("$_wheel")
package() {
- cd "$srcdir"
- pip install --compile --no-deps --ignore-installed --root="$pkgdir" "$_wheel"
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ mkdir -p "$site"
+ unzip "$_wheel" -d "$site"
}