summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarko Luketic2015-08-12 16:35:02 +0200
committerDarko Luketic2015-08-12 16:35:02 +0200
commit5f01e57436b7363cbe678e208e252d3901a2483a (patch)
tree58c7bb8d6a77dd70d832b4e0214d0dc9a985f06b
downloadaur-5f01e57436b7363cbe678e208e252d3901a2483a.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..da47637c06b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = libpam_pwdfile
+ pkgdesc = A PAM module allowing authentication via an /etc/passwd-like file
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/tiwe-de/libpam-pwdfile
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = pam
+ source = https://github.com/tiwe-de/libpam-pwdfile/archive/v1.0.tar.gz
+ sha1sums = a5fd2bd79a3c781b508905709450427f1b28705f
+
+pkgname = libpam_pwdfile
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efbaf2dff288
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# A PAM module allowing authentication via an /etc/passwd-like file
+# Contributor: Mark Dovermann <mdovermann@ceruleanmicrosystems.com>
+# Contributor: David Rosenstrauch <darose@darose.net>
+# Maintainer: Darko Luketic <info@icod.de>
+
+pkgname=libpam_pwdfile
+pkgver=1.0
+pkgrel=1
+pkgdesc="A PAM module allowing authentication via an /etc/passwd-like file"
+arch=('i686' 'x86_64')
+url="https://github.com/tiwe-de/libpam-pwdfile"
+license=('GPL')
+groups=()
+depends=('pam')
+source=(https://github.com/tiwe-de/libpam-pwdfile/archive/v${pkgver}.tar.gz)
+sha1sums=('a5fd2bd79a3c781b508905709450427f1b28705f')
+
+build() {
+ cd "$srcdir/libpam-pwdfile-${pkgver}"
+
+ make
+}
+
+package() {
+ cd "$srcdir/libpam-pwdfile-${pkgver}"
+
+ make PAM_LIB_DIR="$pkgdir/lib/security" INSTALL=$(which install) install
+}
+