summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvert Vorster2023-08-03 10:35:57 +0100
committerEvert Vorster2023-08-03 10:35:57 +0100
commit5f11e0961be8759ce8929b16ac570235924c92f1 (patch)
tree4e3bd073a278d91a127e345ffe44f03f4043e5ac
parentcd86ce495d48b23facf142f1330a63d9cd80df67 (diff)
downloadaur-5f11e0961be8759ce8929b16ac570235924c92f1.tar.gz
Version update
-rw-r--r--.SRCINFO43
-rw-r--r--PKGBUILD42
2 files changed, 37 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4cb2f528a0ba..e82e0aeb6b1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = audacity-qt-git
- pkgdesc = Record and edit audio files-tracking the QT branch in git
- pkgver = 3.3.0.0.r16783
+pkgbase = audacity-local-git
+ pkgdesc = Record and edit audio files - Built with package versions as recommended by Audacity team
+ pkgver = 3.4.0.0.r17467
pkgrel = 1
url = https://audacityteam.org
arch = x86_64
@@ -12,43 +12,24 @@ pkgbase = audacity-qt-git
makedepends = automake
makedepends = libtool
makedepends = git
- makedepends = conan1
+ makedepends = conan
makedepends = catch2
- depends = libmad
- depends = libid3tag
+ depends = gtk3
depends = gtk2
- depends = glib2
- depends = soundtouch
depends = ffmpeg
- depends = vamp-plugin-sdk
- depends = portsmf
depends = portmidi
- depends = twolame
- depends = suil
- depends = lilv
- depends = lv2
- depends = serd
- depends = sord
- depends = sratom
depends = python
- depends = flac
- depends = libvorbis
- depends = libogg
- depends = vamp-plugin-sdk
+ depends = vst3sdk
depends = portaudio
- depends = libsoxr
- depends = libsndfile
- depends = lame
- depends = expat
- depends = alsa-lib
depends = jack
- depends = util-linux
- depends = util-linux-libs
- depends = curl
- depends = zlib
provides = audacity
+ provides = ladspa-host
+ provides = lv2-host
+ provides = vamp-host
+ provides = vst-host
+ provides = vst3-host
conflicts = audacity
source = git+https://github.com/audacity/audacity.git#branch=qt
sha512sums = SKIP
-pkgname = audacity-qt-git
+pkgname = audacity-local-git
diff --git a/PKGBUILD b/PKGBUILD
index a739fe955f72..f25845f669bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,32 @@
# Maintainer: evorster <evorster@gmail.com>
# Contributor: osch <oliver@luced.de>
-pkgname=audacity-qt-git
-pkgver=3.3.0.0.r16783
+pkgname=audacity-local-git
+pkgver=3.4.0.0.r17467
pkgrel=1
-pkgdesc="Record and edit audio files-tracking the QT branch in git"
+pkgdesc="Record and edit audio files - Built with package versions as recommended by Audacity team"
arch=('x86_64')
url="https://audacityteam.org"
license=('GPL2' 'CCPL')
groups=('pro-audio')
-depends=('libmad' 'libid3tag' 'gtk2' 'glib2' 'soundtouch' 'ffmpeg' 'vamp-plugin-sdk'
-'portsmf' 'portmidi' 'twolame' 'suil' 'lilv' 'lv2' 'serd' 'sord' 'sratom' 'python'
-'flac' 'libvorbis' 'libogg' 'vamp-plugin-sdk' 'portaudio' 'libsoxr' 'libsndfile' 'lame'
-'expat' 'alsa-lib' 'jack' 'util-linux' 'util-linux-libs' 'curl' 'zlib')
-makedepends=('cmake' 'autoconf' 'automake' 'libtool' 'git' 'conan1' 'catch2')
-provides=("audacity")
+depends=('gtk3' 'gtk2' 'ffmpeg' 'portmidi' 'python' 'vst3sdk'
+'portaudio' 'jack')
+makedepends=('cmake' 'autoconf' 'automake' 'libtool' 'git' 'conan' 'catch2')
+provides=(
+ audacity
+ ladspa-host
+ lv2-host
+ vamp-host
+ vst-host
+ vst3-host
+ )
conflicts=("audacity")
-source=(
-"git+https://github.com/audacity/audacity.git#branch=qt"
-)
+#
+source=("git+https://github.com/audacity/audacity.git#branch=qt")
+## Comment out the source variable above and uncomment the one below for the last version where the calf plugins work properly
+# There is some sort of regression in later versions. Once it's sorted I'll remove this comment.
+#source=("git+https://github.com/audacity/audacity.git#branch=release-3.1.3")
+#
sha512sums=('SKIP')
pkgver() {
@@ -39,10 +47,11 @@ prepare() {
cd build
depsDir=$(readlink -f ./.offline)
+## To set a custom download directory for Conan2 still seems a bit of a mystery to me.
export CONAN_USER_HOME="$depsDir/conan"
- conan config home
- conan config init
- conan config set storage.download_cache="$CONAN_USER_HOME/download_cache"
+# conan config home
+# conan config init
+# conan config set storage.download_cache="$CONAN_USER_HOME/download_cache"
#Let's not remove it every time, it's a pain building them.
# conan remove "*" --src --builds --force
@@ -50,7 +59,7 @@ prepare() {
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-Daudacity_use_ffmpeg=loaded \
- -Daudacity_use_vst3sdk=system
+ -Daudacity_use_vst3sdk=system
# -Daudacity_has_vst3=Off \
# -DAUDACITY_BUILD_LEVEL=2 \
# -Daudacity_has_networking=off \
@@ -73,4 +82,3 @@ cd build
package() {
make -C build DESTDIR="${pkgdir}" install
}
-