summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgithub-actions[bot]2023-11-13 16:26:22 +0000
committergithub-actions[bot]2023-11-13 16:26:22 +0000
commit5f4f9ca86efbf1085be7a5e01c0271d10ca27b4c (patch)
tree0da2788a9039b16b1725179ecefe3386b6a97ebe
parentb1b1218fcea8cb42415c93811c80acfd66336d9c (diff)
downloadaur-5f4f9ca86efbf1085be7a5e01c0271d10ca27b4c.tar.gz
Automatic update
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD63
2 files changed, 40 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4534fc6efead..d762193b587f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,28 @@
pkgbase = xkb-switch-i3-git
pkgdesc = Program that allows to query and change the XKB layout state (with i3wm auto-switch mode)
- pkgver = 1.7.1.r0.g19d223f
- pkgrel = 1
+ pkgver = 2.0.1+i3_5
+ pkgrel = 3
url = https://github.com/zebradil/xkb-switch-i3
arch = i686
arch = x86_64
- license = GPL3
- makedepends = git
+ license = MIT
makedepends = cmake
- depends = libx11
- depends = libxkbfile
+ makedepends = git
+ makedepends = i3-wm
+ makedepends = libsigc++
+ makedepends = libx11
+ makedepends = libxkbfile
depends = i3-wm
- depends = libsigc++
depends = jsoncpp
+ depends = libsigc++
+ depends = libx11
+ depends = libxkbfile
provides = xkb-switch
conflicts = xkb-switch
+ conflicts = xkb-switch-i3
source = git+https://github.com/zebradil/xkb-switch-i3.git#branch=master
source = git+https://github.com/drmgc/i3ipcpp.git
- sha1sums = SKIP
- sha1sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = xkb-switch-i3-git
diff --git a/PKGBUILD b/PKGBUILD
index 2619d5137b48..a5eab9fccff2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,34 @@
# Maintainer: German Lashevich <german.lashevich@gmail.com>
# Contributor: Orestis Floros <orestisf1993@gmail.com>
# Contributor: Doron Behar <doron.behar@gmail.com>
-
-_pkgname=xkb-switch-i3
-
+#
+# Source: https://github.com/zebradil/aur
+#
+# shellcheck disable=SC2034,SC2154
pkgname=xkb-switch-i3-git
-pkgver=1.7.1.r0.g19d223f
-pkgrel=1
-pkgdesc='Program that allows to query and change the XKB layout state (with i3wm auto-switch mode)'
-conflicts=('xkb-switch')
-provides=('xkb-switch')
-arch=('i686' 'x86_64')
-url="https://github.com/zebradil/${_pkgname}"
-license=('GPL3')
-depends=('libx11' 'libxkbfile' 'i3-wm' 'libsigc++' 'jsoncpp')
-makedepends=('git' 'cmake')
-source=(
- "git+https://github.com/zebradil/${_pkgname}.git#branch=master"
- "git+https://github.com/drmgc/i3ipcpp.git"
-)
-sha1sums=(
- 'SKIP'
- 'SKIP'
-)
-
-pkgver() {
- cd "${_pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-build() {
- cd "${srcdir}/${_pkgname}"
- git submodule init
- git config "submodule.i3ipc++.url" "${srcdir}/i3ipcpp"
- git submodule update
-
- cmake -DCMAKE_INSTALL_PREFIX=/usr .
+pkgver=2.0.1+i3_5
+pkgrel=3
+pkgdesc="Program that allows to query and change the XKB layout state (with i3wm auto-switch mode)"
+url="https://github.com/zebradil/xkb-switch-i3"
+arch=(i686 x86_64)
+license=(MIT)
+depends=(i3-wm jsoncpp libsigc++ libx11 libxkbfile)
+makedepends=(cmake git i3-wm libsigc++ libx11 libxkbfile)
+conflicts=(xkb-switch xkb-switch-i3)
+provides=(xkb-switch)
+source=(git+https://github.com/zebradil/xkb-switch-i3.git#branch=master git+https://github.com/drmgc/i3ipcpp.git)
+sha256sums=(SKIP SKIP)
+build ()
+{
+ cd "${srcdir}/${pkgname%-git}";
+ git submodule init;
+ git config "submodule.i3ipc++.url" "${srcdir}/i3ipcpp";
+ git -c protocol.file.allow=always submodule update;
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .;
make
}
-
-package() {
- cd "${srcdir}/${_pkgname}"
+package ()
+{
+ cd "${srcdir}/${pkgname%-git}";
make DESTDIR="$pkgdir/" install
}