summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2015-06-13 17:59:16 +0200
committerMuflone2015-06-13 17:59:16 +0200
commit5f4fbbda2a567ebc1af328e9c29bc01d98698f19 (patch)
tree12f7c460a5776a0d549811487a7fca75ecc7a31f
downloadaur-5f4fbbda2a567ebc1af328e9c29bc01d98698f19.tar.gz
Initial import
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD68
-rw-r--r--defcon-128.pngbin0 -> 18548 bytes
-rw-r--r--defcon-16.pngbin0 -> 817 bytes
-rw-r--r--defcon-32.pngbin0 -> 2318 bytes
-rw-r--r--defcon-48.pngbin0 -> 4168 bytes
-rw-r--r--defcon-64.pngbin0 -> 6839 bytes
-rw-r--r--defcon.desktop10
-rw-r--r--defcon.install12
9 files changed, 126 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e58c0240d13
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = defcon
+ pkgdesc = Global Thermonuclear War game
+ pkgver = 1.60
+ pkgrel = 1
+ url = http://www.introversion.co.uk/defcon/
+ install = defcon.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = glu
+ depends = mesa
+ depends = sdl
+ depends = alsa-plugins
+ depends = libpulse
+ depends = desktop-file-utils
+ depends = gtk-update-icon-cache
+ depends = hicolor-icon-theme
+ depends = xdg-utils
+ noextract = defcon-1.60.sh
+ source = defcon-1.60.sh::http://www.introversion.co.uk/defcon/downloads/defcon.sh
+ source = defcon-16.png
+ source = defcon-32.png
+ source = defcon-48.png
+ source = defcon-64.png
+ source = defcon-128.png
+ source = defcon.desktop
+ md5sums = b8533e05218cc2452b6debed263224f0
+ md5sums = 5fe8db2ddd9d8b729bbdc45ef8ed952e
+ md5sums = 9f644374d718126ddf5a1b8b6b4bf25e
+ md5sums = ba986cfe6c1cdfb2a415c0c551c840e2
+ md5sums = 15e3ad4bea89ee96d62235ca371fb403
+ md5sums = a75d3a0b29668e3ebd2afcaec5d2b199
+ md5sums = e470f70aa1c72f6e37b77e27d769da3f
+
+pkgname = defcon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8cc4fffe3c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Muflone <webreg@vbsimple.net>
+# Contributor: Tony Dodd <arch@recalcitrance.net>
+# Contributor: Jonathan Frazier <eyeswide@gmail.com>
+pkgname=defcon
+pkgver=1.60
+pkgrel=1
+pkgdesc="Global Thermonuclear War game"
+arch=('i686' 'x86_64')
+url="http://www.introversion.co.uk/defcon/"
+license=("custom")
+depends=('glu' 'mesa' 'sdl' 'alsa-plugins' 'libpulse'
+ 'desktop-file-utils' 'gtk-update-icon-cache' 'hicolor-icon-theme' 'xdg-utils')
+source=("${pkgname}-${pkgver}.sh"::"http://www.introversion.co.uk/${pkgname}/downloads/${pkgname}.sh"
+ "${pkgname}-16.png"
+ "${pkgname}-32.png"
+ "${pkgname}-48.png"
+ "${pkgname}-64.png"
+ "${pkgname}-128.png"
+ "${pkgname}.desktop")
+md5sums=('b8533e05218cc2452b6debed263224f0'
+ '5fe8db2ddd9d8b729bbdc45ef8ed952e'
+ '9f644374d718126ddf5a1b8b6b4bf25e'
+ 'ba986cfe6c1cdfb2a415c0c551c840e2'
+ '15e3ad4bea89ee96d62235ca371fb403'
+ 'a75d3a0b29668e3ebd2afcaec5d2b199'
+ 'e470f70aa1c72f6e37b77e27d769da3f')
+install="${pkgname}.install"
+noextract=("${pkgname}-${pkgver}.sh")
+
+build() {
+ sh "${pkgname}-${pkgver}.sh" --noexec --keep
+ # Extract archives from Nixstaller archive
+ lzmadec "tmp/subarch" | tar xf - instarchive_all instarchive_all_x86 instarchive_all_x86_64
+ lzmadec "instarchive_all" | tar xf -
+ lzmadec "instarchive_all_x86" | tar xf -
+ lzmadec "instarchive_all_x86_64" | tar xf -
+}
+
+package() {
+ # install desktop file and icon
+ install -m 755 -D "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -m 644 -D "${pkgname}-16.png" "$pkgdir/usr/share/icons/hicolor/16x16/apps/${pkgname}.png"
+ install -m 644 -D "${pkgname}-32.png" "$pkgdir/usr/share/icons/hicolor/32x32/apps/${pkgname}.png"
+ install -m 644 -D "${pkgname}-48.png" "$pkgdir/usr/share/icons/hicolor/48x48/apps/${pkgname}.png"
+ install -m 644 -D "${pkgname}-64.png" "$pkgdir/usr/share/icons/hicolor/64x64/apps/${pkgname}.png"
+ install -m 644 -D "${pkgname}-128.png" "$pkgdir/usr/share/icons/hicolor/128x128/apps/${pkgname}.png"
+
+ #install program files
+ cd "Defcon"
+ if [ "${CARCH}" = "x36_64" ]
+ then
+ install -m 755 -D "defcon.bin.x86_64" "${pkgdir}/usr/share/${pkgname}/defcon"
+ else
+ install -m 755 -D "defcon.bin.x86" "${pkgdir}/usr/share/${pkgname}/defcon"
+ fi
+ install -m 644 -t "${pkgdir}/usr/share/${pkgname}" "manual.pdf"
+ install -m 644 -t "${pkgdir}/usr/share/${pkgname}" "linux.txt"
+ install -m 644 -t "${pkgdir}/usr/share/${pkgname}" "main.dat"
+ install -m 644 -t "${pkgdir}/usr/share/${pkgname}" "sounds.dat"
+
+ #install symlinks
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/usr/share/${pkgname}/defcon" "${pkgdir}/usr/bin/${pkgname}"
+ ln -s "/usr/bin/xdg-open" "${pkgdir}/usr/share/${pkgname}/xdg-open.sh"
+
+ # Install license
+ install -D -m 644 "license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
+}
diff --git a/defcon-128.png b/defcon-128.png
new file mode 100644
index 000000000000..329b975ec7e1
--- /dev/null
+++ b/defcon-128.png
Binary files differ
diff --git a/defcon-16.png b/defcon-16.png
new file mode 100644
index 000000000000..c68cc67611f1
--- /dev/null
+++ b/defcon-16.png
Binary files differ
diff --git a/defcon-32.png b/defcon-32.png
new file mode 100644
index 000000000000..b81a733c101c
--- /dev/null
+++ b/defcon-32.png
Binary files differ
diff --git a/defcon-48.png b/defcon-48.png
new file mode 100644
index 000000000000..b4cb9c8faee6
--- /dev/null
+++ b/defcon-48.png
Binary files differ
diff --git a/defcon-64.png b/defcon-64.png
new file mode 100644
index 000000000000..a6265b6b3222
--- /dev/null
+++ b/defcon-64.png
Binary files differ
diff --git a/defcon.desktop b/defcon.desktop
new file mode 100644
index 000000000000..fdfa01e891e8
--- /dev/null
+++ b/defcon.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Defcon
+GenericName=Global Thermonuclear War
+Comment=The World's first Genocide 'em up
+Exec=defcon
+Terminal=false
+Type=Application
+Icon=defcon
+Categories=Application;Game;StrategyGame;
diff --git a/defcon.install b/defcon.install
new file mode 100644
index 000000000000..71627fa64211
--- /dev/null
+++ b/defcon.install
@@ -0,0 +1,12 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}