summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkreon2015-07-07 02:17:52 +0300
committerkreon2015-07-07 02:21:02 +0300
commit5f77d282c65558d6b874b9e7fac4400258437d38 (patch)
tree2654b9d140ac34b5869f22c2abc284936fbb3045
downloadaur-5f77d282c65558d6b874b9e7fac4400258437d38.tar.gz
initial commit
-rw-r--r--.AURINFO18
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD32
-rw-r--r--heli-x3
-rw-r--r--heli-x.desktop11
-rw-r--r--heli-x.install9
-rw-r--r--heli-x.pngbin0 -> 7517 bytes
7 files changed, 96 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..4c46b62366c2
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,18 @@
+pkgbase = heli-x
+ pkgdesc = HELI-X RC Flight Simulator
+ pkgver = 5
+ pkgrel = 1
+ url = http://www.heli-x.info
+ install = heli-x.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = java-runtime>=6
+ source = http://www.heli-x.info/1405/HELI-X5.tar.gz
+ source = heli-x.desktop
+ source = heli-x.png
+ source = heli-x.install
+ source = heli-x
+
+pkgname = heli-x
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51af932de669
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = heli-x
+ pkgdesc = HELI-X RC Flight Simulator
+ pkgver = 5
+ pkgrel = 1
+ url = http://www.heli-x.info
+ install = heli-x.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = java-runtime>=6
+ source = http://www.heli-x.info/1405/HELI-X5.tar.gz
+ source = heli-x.desktop
+ source = heli-x.png
+ source = heli-x.install
+ source = heli-x
+ md5sums = 954c7c4123800c1bc9247294f5b2b791
+ md5sums = a7f340949236c7c4afa3851b313efc4b
+ md5sums = 30af503bd32a62decb15f8ca5e03d90e
+ md5sums = c58fca72b0c1b257196ea6d15e5c11c2
+ md5sums = a359f2c641c60a732e62da8d39a9be55
+
+pkgname = heli-x
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aee645e091ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Ivan Agarkov <ivan.agarkov@gmail.com>
+pkgname=heli-x
+pkgver=5
+pkgrel=1
+pkgdesc='HELI-X RC Flight Simulator'
+arch=('i686' 'x86_64')
+url='http://www.heli-x.info'
+license=('unknown')
+depends=('java-runtime>=6')
+install=heli-x.install
+source=('http://www.heli-x.info/1405/HELI-X5.tar.gz' 'heli-x.desktop' 'heli-x.png' 'heli-x.install' 'heli-x')
+md5sums=('954c7c4123800c1bc9247294f5b2b791'
+ 'a7f340949236c7c4afa3851b313efc4b'
+ '30af503bd32a62decb15f8ca5e03d90e'
+ 'c58fca72b0c1b257196ea6d15e5c11c2'
+ 'a359f2c641c60a732e62da8d39a9be55')
+package() {
+ cd "$srcdir/HELI-X5"
+ mkdir -p "$pkgdir/opt/heli-x"
+ cp -r * "$pkgdir/opt/heli-x"
+ cd "$pkgdir/opt/heli-x"
+ find . -iname '*.dll'|xargs rm
+ find . -iname '*.bat'|xargs rm
+ find . -type f|xargs chmod 644
+ find . -type d|xargs chmod 777
+ mkdir -p "$pkgdir/usr/bin/"
+ install -m 755 "$srcdir/heli-x" "$pkgdir/usr/bin/heli-x"
+ mkdir -p "$pkgdir/usr/share/applications"
+ cp "$srcdir/heli-x.desktop" "$pkgdir/usr/share/applications/"
+ mkdir -p "$pkgdir/usr/share/icons/hicolor/64x64/apps"
+ cp "$srcdir/heli-x.png" "$pkgdir/usr/share/icons/hicolor/64x64/apps/"
+}
diff --git a/heli-x b/heli-x
new file mode 100644
index 000000000000..b9f561011e84
--- /dev/null
+++ b/heli-x
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /opt/heli-x/
+sh runHELI-X.sh
diff --git a/heli-x.desktop b/heli-x.desktop
new file mode 100644
index 000000000000..0df2903aaba2
--- /dev/null
+++ b/heli-x.desktop
@@ -0,0 +1,11 @@
+#!/usr/bin/env xdg-open
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=HELI-X
+Comment=HELI-X 5 RC Flight Simulator
+Exec=heli-x
+Icon=heli-x
+Terminal=false
+StartupNotify=false
+Categories=Game; \ No newline at end of file
diff --git a/heli-x.install b/heli-x.install
new file mode 100644
index 000000000000..ea579ebcada3
--- /dev/null
+++ b/heli-x.install
@@ -0,0 +1,9 @@
+post_install() {
+ if [ -x usr/bin/gtk-update-icon-cache ]; then usr/bin/gtk-update-icon-cache usr/share/icons/hicolor/; fi
+ if [ -x usr/bin/update-desktop-database ]; then usr/bin/update-desktop-database; fi
+}
+
+post_remove() {
+ if [ -x usr/bin/gtk-update-icon-cache ]; then usr/bin/gtk-update-icon-cache usr/share/icons/hicolor/; fi
+ if [ -x usr/bin/update-desktop-database ]; then usr/bin/update-desktop-database; fi
+}
diff --git a/heli-x.png b/heli-x.png
new file mode 100644
index 000000000000..cf411ce4b92a
--- /dev/null
+++ b/heli-x.png
Binary files differ