summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2021-02-10 01:05:13 +0100
committerMassimiliano Torromeo2021-02-10 01:05:13 +0100
commit5f7f668c190c694eccab867080e225f90a85a454 (patch)
tree620c7b4e96352f9c9cdd7e01ef7f19473947050f
downloadaur-5f7f668c190c694eccab867080e225f90a85a454.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore17
-rw-r--r--PKGBUILD23
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e551d2d94fa2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-rmrl
+ pkgdesc = reMarkable Rendering Library
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://github.com/rschroll/rmrl/
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ depends = python-pdfrw
+ depends = python-reportlab
+ depends = python-pyxdg
+ depends = python-svglib
+ source = https://files.pythonhosted.org/packages/source/r/rmrl/rmrl-0.1.2.tar.gz
+ sha256sums = 8c8e757af5ca3eb7475f56803f7f37256fe4c5cad3a9ea5ad7534b2ebd172447
+
+pkgname = python-rmrl
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9b97681014e9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,17 @@
+*.zip
+*.jar
+*.tar
+*.tgz
+*.tbz2
+*.gz
+*.bz2
+*.xz
+*.gem
+*.run
+*.deb
+*.rpm
+*.sig
+*.log
+/src
+/pkg
+*.kate-swp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad4081987e3a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+
+pkgname=python-rmrl
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="reMarkable Rendering Library"
+arch=(any)
+url="https://github.com/rschroll/rmrl/"
+license=('GPL')
+depends=('python-pdfrw' 'python-reportlab' 'python-pyxdg' 'python-svglib')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/r/rmrl/rmrl-$pkgver.tar.gz")
+sha256sums=('8c8e757af5ca3eb7475f56803f7f37256fe4c5cad3a9ea5ad7534b2ebd172447')
+
+build() {
+ cd "$srcdir"/rmrl-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir"/rmrl-$pkgver
+ python setup.py install -O1 --skip-build --root="$pkgdir"
+}