summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-11 01:25:58 -0600
committerBrian Bidulock2015-06-11 01:25:58 -0600
commit5fcffc040ab90824f5957c73e782360df8df50a5 (patch)
tree049f1b4be972c8252f9c24c5d701a2465b79aecc
downloadaur-5fcffc040ab90824f5957c73e782360df8df50a5.tar.gz
initial version
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD50
-rw-r--r--netcdf-perl.patch23
-rw-r--r--netcdf.patch13
4 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b909c2445cd2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = perl-netcdf
+ pkgdesc = A perl extension module for scientific data access via the netCDF API
+ pkgver = 1.2.4
+ pkgrel = 1
+ url = http://www.unidata.ucar.edu/software/netcdf-perl/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = netcdf
+ depends = perl
+ provides = netcdf-perl-1.2.4
+ conflicts = netcdf-perl
+ replaces = netcdf-perl
+ options = !emptydirs
+ source = ftp://ftp.unidata.ucar.edu/pub/netcdf-perl/netcdf-perl-1.2.4.tar.gz
+ source = netcdf-perl.patch
+ source = netcdf.patch
+ source = ftp://ftp.unidata.ucar.edu/pub/netcdf/old/netcdf-2.4.3.tar.Z
+ md5sums = 36b517662bda6a12a76f817acb49a993
+ md5sums = 290b8c4efe0957e2a17bc6962464c0dc
+ md5sums = 645d9746d0a2a2a63e3af7e11b727da2
+ md5sums = e9371fd9f10dd147374bda38028fd9b1
+
+pkgname = perl-netcdf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..989a650343c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
+# Contributor: graziano <giuliani@lamma.rete.toscana.it>
+
+pkgname=perl-netcdf
+_pkgname=netcdf-perl
+pkgver=1.2.4
+pkgrel=1
+pkgdesc="A perl extension module for scientific data access via the netCDF API"
+arch=('i686' 'x86_64')
+url="http://www.unidata.ucar.edu/software/netcdf-perl/"
+license=('custom')
+conflicts=($_pkgname)
+replaces=($_pkgname)
+provides=($_pkgname-$pkgver)
+depends=('netcdf' 'perl')
+options=('!emptydirs')
+source=("ftp://ftp.unidata.ucar.edu/pub/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
+ "${_pkgname}.patch" "netcdf.patch"
+ "ftp://ftp.unidata.ucar.edu/pub/netcdf/old/netcdf-2.4.3.tar.Z")
+md5sums=('36b517662bda6a12a76f817acb49a993'
+ '290b8c4efe0957e2a17bc6962464c0dc'
+ '645d9746d0a2a2a63e3af7e11b727da2'
+ 'e9371fd9f10dd147374bda38028fd9b1')
+
+build() {
+ cd $srcdir/netcdf-2.4.3
+ patch -p1 <"$srcdir"/netcdf.patch
+ cd $srcdir/$_pkgname-$pkgver/src
+ patch -p2 <"$srcdir/${_pkgname}.patch"
+ PERL_MANDIR=/usr/share/man/man3 \
+ CPP_NETCDF="-I/usr/include" \
+ LD_NETCDF="-L/usr/lib -lnetcdf" \
+ ./configure --prefix=/usr --mandir=/usr/share/man || return 1
+ cd perl
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+package() {
+ cd $srcdir/$_pkgname-$pkgver/src
+ install -Dm0644 netCDFPerl.1 "${pkgdir}"/usr/share/man/man3/NetCDF.3pm
+ install -Dm0644 $srcdir/netcdf-2.4.3/src/doc/netcdf.3 "$pkgdir"/usr/share/man/man3/netcdf2.3
+ install -Dm0644 COPYRIGHT "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+ cd perl
+ make DESTDIR=$pkgdir install
+ find $pkgdir -name '.packlist' -delete
+ find $pkgdir -name '*.pod' -delete
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/netcdf-perl.patch b/netcdf-perl.patch
new file mode 100644
index 000000000000..e3e84d1a33ff
--- /dev/null
+++ b/netcdf-perl.patch
@@ -0,0 +1,23 @@
+diff -purN netcdf-perl-1.2.4.orig/src/netCDFPerl.1 netcdf-perl-1.2.4/src/netCDFPerl.1
+--- netcdf-perl-1.2.4.orig/src/netCDFPerl.1 1999-07-21 10:38:27.000000000 -0600
++++ netcdf-perl-1.2.4/src/netCDFPerl.1 2013-03-27 00:40:13.000000000 -0600
+@@ -1,7 +1,8 @@
+ .\" $Id: netCDFPerl.1,v 1.7 1999/07/21 16:38:27 steve Exp $
+-.TH netCDFPerl 1 "$Date: 1999/07/21 16:38:27 $" "Printed: \n(yr-\n(mo-\n(dy" "UNIDATA UTILITIES"
++.nr yr +1900
++.TH NetCDF 3 "$Date: 1999/07/21 16:38:27 $" "Printed: \n(yr-\n(mo-\n(dy" "UNIDATA UTILITIES"
+ .SH NAME
+-netCDFPerl \- perl extension for netCDF dataset access
++NetCDF \- perl extension for netCDF dataset access
+ .SH SYNOPSIS
+ .na
+ .nh
+@@ -15,7 +16,7 @@ NetCDF::create("foo.nc", NetCDF::CLOBBER
+ .hy
+ .SH DESCRIPTION
+ .PP
+-\fBnetCDFPerl\fP is a Perl 5 extension-module interface to the services
++\fBNetCDF\fP is a Perl 5 extension-module interface to the services
+ provided by the netCDF version 2 API, netcdf2(3).
+ .PP
+ The functions in the netCDF version 2 library can be accessed by a Perl 5 script
diff --git a/netcdf.patch b/netcdf.patch
new file mode 100644
index 000000000000..aacc36ffb642
--- /dev/null
+++ b/netcdf.patch
@@ -0,0 +1,13 @@
+diff -purN netcdf-2.4.3.orig/src/doc/netcdf.3 netcdf-2.4.3/src/doc/netcdf.3
+--- netcdf-2.4.3.orig/src/doc/netcdf.3 1995-07-18 13:39:39.000000000 -0600
++++ netcdf-2.4.3/src/doc/netcdf.3 2013-03-27 00:55:16.000000000 -0600
+@@ -1,6 +1,7 @@
+-.TH NETCDF 3 "26 February 1993" "Printed: \n(yr.\n(mo.\n(dy" "UNIDATA LIBRARY FUNCTIONS"
++.nr yr +1900
++.TH NETCDF2 3 "26 February 1993" "Printed: \n(yr.\n(mo.\n(dy" "UNIDATA LIBRARY FUNCTIONS"
+ .SH NAME
+-netcdf \- Unidata Network Common Data Form (netCDF) library
++netcdf2 \- Unidata Network Common Data Form (netCDF) library
+ .SH SYNOPSIS
+ .ft B
+ .na