summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladislav Nepogodin2023-08-25 02:50:52 +0400
committerVladislav Nepogodin2023-08-25 02:50:52 +0400
commit60040e51bf76037567a3c22ec10813c85bc1e343 (patch)
tree7ede66af3d733d42d647e0f70ae5a1bab5b7b3f0
parent36dd41d0098046e306327d0d2a7914b2ddf9ca81 (diff)
downloadaur-60040e51bf76037567a3c22ec10813c85bc1e343.tar.gz
Bump version
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f596e3f07bd..beb97165aed4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ananicy-cpp
pkgdesc = Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage.
- pkgver = 1.1.0
- pkgrel = 2
+ pkgver = 1.1.1
+ pkgrel = 1
url = https://gitlab.com/ananicy-cpp/ananicy-cpp
arch = x86_64
arch = x86_64_v3
@@ -17,15 +17,13 @@ pkgbase = ananicy-cpp
makedepends = nlohmann-json
makedepends = bpf
depends = fmt
- depends = spdlog
- depends = nlohmann-json
depends = systemd
depends = libelf
depends = zlib
depends = libbpf
optdepends = ananicy-rules-git: community rules
optdepends = ananicy-rules: Rules based for ananicy-cpp
- source = https://gitlab.com/ananicy-cpp/ananicy-cpp/-/archive/v1.1.0/ananicy-cpp-v1.1.0.tar.gz
- sha512sums = d6204713c5119739cd332959603563d395b1bf3c1aa2459d06f02b4e7d19e7e704ead97781971fce882d885e46d217c05bccd961d37747bd928268b51edfda07
+ source = https://gitlab.com/ananicy-cpp/ananicy-cpp/-/archive/v1.1.1/ananicy-cpp-v1.1.1.tar.gz
+ sha512sums = 61fe40a2da09b7d6a6a92ca6a2c7ba273200a83e893e5c5156edfbeb2fdfa0bdb4cdae402d6b1b4a1d12c5ea820e3d2e1a6d287d1314e8daf1889c3f0e7aa5ce
pkgname = ananicy-cpp
diff --git a/PKGBUILD b/PKGBUILD
index 7c7d859e7696..3bb016f06d5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Antoine Viallon <antoine@lesviallon.fr>
pkgname=ananicy-cpp
-_pkgver=1.1.0
+_pkgver=1.1.1
pkgver=${_pkgver//-/.}
-pkgrel=2
+pkgrel=1
pkgdesc="Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage."
arch=(x86_64 x86_64_v3 i386 armv7h aarch64 pentium4)
url="https://gitlab.com/ananicy-cpp/ananicy-cpp"
license=('GPLv3')
-depends=(fmt spdlog nlohmann-json systemd libelf zlib libbpf)
+depends=(fmt systemd libelf zlib libbpf)
makedepends=(cmake ninja clang git nlohmann-json bpf)
optdepends=("ananicy-rules-git: community rules"
"ananicy-rules: Rules based for ananicy-cpp")
source=("https://gitlab.com/ananicy-cpp/${pkgname}/-/archive/v${_pkgver}/${pkgname}-v${_pkgver}.tar.gz")
-sha512sums=('d6204713c5119739cd332959603563d395b1bf3c1aa2459d06f02b4e7d19e7e704ead97781971fce882d885e46d217c05bccd961d37747bd928268b51edfda07')
+sha512sums=('61fe40a2da09b7d6a6a92ca6a2c7ba273200a83e893e5c5156edfbeb2fdfa0bdb4cdae402d6b1b4a1d12c5ea820e3d2e1a6d287d1314e8daf1889c3f0e7aa5ce')
build() {
cd "${srcdir}/${pkgname}-v${_pkgver}"
@@ -24,11 +24,12 @@ build() {
export CXXFLAGS="${CXXFLAGS}"
export LDFLAGS="${LDFLAGS}"
+ # disable system spdlog
cmake -S . -Bbuild \
-GNinja \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DUSE_EXTERNAL_SPDLOG=ON \
+ -DUSE_EXTERNAL_SPDLOG=OFF \
-DUSE_EXTERNAL_JSON=ON \
-DUSE_EXTERNAL_FMTLIB=ON \
-DENABLE_SYSTEMD=ON \