summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormalahx2016-07-11 12:13:57 +0200
committermalahx2016-07-11 12:13:57 +0200
commit60146a9788ca948b3e1e21375c796ffa81420c4e (patch)
treed074627f6161f507f8211c859ea959ee3e425e6a
downloadaur-60146a9788ca948b3e1e21375c796ffa81420c4e.tar.gz
initial commit of mono 4.2
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD55
-rw-r--r--mono42.install7
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aecbd701f12a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = mono42
+ pkgdesc = Free implementation of the .NET platform including runtime and compiler
+ pkgver = 4.2.4.4
+ pkgrel = 1
+ url = http://www.mono-project.com/
+ install = mono42.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL2.1
+ license = MPL
+ license = custom:MITX11
+ depends = zlib
+ depends = libgdiplus>=3.8
+ depends = sh
+ depends = python
+ depends = ca-certificates
+ provides = monodoc
+ provides = mono=4.2.4.4
+ conflicts = monodoc
+ conflicts = mono
+ source = http://download.mono-project.com/sources/mono/mono-4.2.4.4.tar.bz2
+ sha256sums = ae74292c672e276276edc5461914f3e184d427a7a2ac099d3ce2640abe5dc0c6
+
+pkgname = mono42
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ee1fbdc1322
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# $Id$
+# Maintainer: Malah <malah@neuf.fr>
+# Contributor: Daniel Isenmann <daniel@archlinux.org>
+# Contributor: Brice Carpentier <brice@dlfp.org>
+
+pkgname=mono42
+_pkgname=mono
+pkgver=4.2.4.4
+_pkgver=4.2.4
+pkgrel=1
+pkgdesc="Free implementation of the .NET platform including runtime and compiler"
+arch=(i686 x86_64)
+license=('GPL' 'LGPL2.1' 'MPL' 'custom:MITX11')
+url="http://www.mono-project.com/"
+depends=('zlib' 'libgdiplus>=3.8' 'sh' 'python' 'ca-certificates')
+provides=('monodoc' "mono=${pkgver}")
+conflicts=('monodoc' 'mono')
+install="${pkgname}.install"
+source=(http://download.mono-project.com/sources/mono/${_pkgname}-${pkgver}.tar.bz2)
+sha256sums=('ae74292c672e276276edc5461914f3e184d427a7a2ac099d3ce2640abe5dc0c6')
+
+build() {
+ cd "${srcdir}"/${_pkgname}-${_pkgver}
+
+ # build mono
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --bindir=/usr/bin \
+ --sbindir=/usr/bin \
+ --with-mcs-docs=no
+ make
+
+ # build jay
+ cd "${srcdir}"/${_pkgname}-${_pkgver}/mcs/jay
+ make
+}
+
+package() {
+ cd "${srcdir}"/${_pkgname}-${_pkgver}
+ make DESTDIR="${pkgdir}" install
+
+ # install jay
+ pushd "${srcdir}"/${_pkgname}-${_pkgver}/mcs/jay
+ make DESTDIR="${pkgdir}" prefix=/usr INSTALL=../../install-sh install
+ popd
+
+ #install license
+ mkdir -p "${pkgdir}"/usr/share/licenses/${_pkgname}
+ install -m644 mcs/MIT.X11 "${pkgdir}"/usr/share/licenses/${_pkgname}/
+
+ #fix .pc file to be able to request mono on what it depends, fixes #go-oo build
+ sed -i -e "s:#Requires:Requires:" "${pkgdir}"/usr/lib/pkgconfig/mono.pc
+ sed -i -e "s:/2.0/:/4.5/:g" "${pkgdir}"/usr/lib/pkgconfig/mono-nunit.pc
+}
diff --git a/mono42.install b/mono42.install
new file mode 100644
index 000000000000..cd0363b84a9f
--- /dev/null
+++ b/mono42.install
@@ -0,0 +1,7 @@
+post_install() {
+ post_upgrade
+}
+
+post_upgrade() {
+ cert-sync /etc/ssl/certs/ca-certificates.crt
+}