summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Feuls2015-06-09 14:13:13 +0200
committerCarsten Feuls2015-06-09 14:13:13 +0200
commit601b016f33a772da2cf5e72329939333d3787bf9 (patch)
treeacb9bae1bab67c3ca431d4d0b1b68d81af4a70c3
downloadaur-601b016f33a772da2cf5e72329939333d3787bf9.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD25
-rw-r--r--cumulus.desktop14
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ec20ec43be1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = cumulus
+ pkgdesc = Cumulus is a free and Open Source flight computer for Linux
+ pkgver = 5.21.0
+ pkgrel = 1
+ url = http://www.kflog.org/cumulus/
+ arch = i686
+ arch = x86_64
+ arch = armv5h
+ arch = armv6h
+ arch = armv7h
+ license = custom
+ depends = qt4
+ source = https://github.com/kflog-project/Cumulus/archive/master.zip
+ source = cumulus.desktop
+ sha256sums = 03669ac4302c4bf0d607f0a3d50cf3f0cbfff9a13dc745f327e48339093a3fbf
+ sha256sums = efd04ecd966383d491dbd1fcfe22918c56653825a57c5778de56dc040e685087
+
+pkgname = cumulus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e41dbae87efc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: archlinux at carstenfeuls dot de
+pkgname=cumulus
+pkgver=5.21.0
+pkgrel=1
+pkgdesc="Cumulus is a free and Open Source flight computer for Linux"
+arch=('i686' 'x86_64' 'armv5h' 'armv6h' 'armv7h')
+url="http://www.kflog.org/cumulus/"
+license=('custom')
+depends=('qt4')
+source=('https://github.com/kflog-project/Cumulus/archive/master.zip'
+ 'cumulus.desktop')
+sha256sums=('03669ac4302c4bf0d607f0a3d50cf3f0cbfff9a13dc745f327e48339093a3fbf'
+ 'efd04ecd966383d491dbd1fcfe22918c56653825a57c5778de56dc040e685087')
+
+build() {
+ cd "${srcdir}/Cumulus-master"
+ make -f Makefile.X11 all
+}
+
+package() {
+ cd "${srcdir}/Cumulus-master"
+ install -d ${pkgdir}/usr/share/applications
+ install --mode=644 ${srcdir}/cumulus.desktop ${pkgdir}/usr/share/applications/
+ make INSTALL_ROOT=${pkgdir}/opt/cumulus -f Makefile.X11 install
+}
diff --git a/cumulus.desktop b/cumulus.desktop
new file mode 100644
index 000000000000..278ffe123830
--- /dev/null
+++ b/cumulus.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Cumulus
+Comment=A flight navigation aid for glider pilots and others
+Comment[de]=Eine Flug Navigations Hilfe für Segelflieger und andere
+Exec=/opt/cumulus/bin/cumulus
+Icon=/opt/cumulus/icons/cumulus-desktop48x48.png
+Path=
+Terminal=false
+StartupNotify=false
+GenericName=Flight navigation aid
+GenericName[de]=Flug Navigations Hilfe
+Categories=Utility;Qt;Navigation \ No newline at end of file