summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lowman2019-12-20 17:14:49 +0100
committerMichael Lowman2019-12-20 17:14:49 +0100
commit603c4494bbc1cc54f8af90c80266859cec5208ee (patch)
treed9c6c559ccaba02e8a3d81b2a6ae8e5f404611ac
parent6ec606f7b432ed88d79d0a007a5625abf3298fcc (diff)
downloadaur-603c4494bbc1cc54f8af90c80266859cec5208ee.tar.gz
Update PKGBUILD to match latest community build
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD76
-rw-r--r--sssd.service12
3 files changed, 43 insertions, 74 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b3726f75794..704f11c104e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,44 +1,29 @@
-# Generated by mksrcinfo v8
-# Thu Mar 2 18:58:03 UTC 2017
pkgbase = sssd-git
pkgdesc = System Security Services Daemon
- pkgver = 1.13.0.r69.gafa6ac7
+ pkgver = 2.2.3.r5.g58a67cd38
pkgrel = 1
- url = https://fedorahosted.org/sssd/
- arch = i686
+ url = https://pagure.io/SSSD/sssd
arch = x86_64
license = GPL3
makedepends = docbook-xsl
makedepends = doxygen
makedepends = python
- makedepends = python2
makedepends = samba
- depends = augeas
+ makedepends = systemd
depends = bind
depends = c-ares
depends = cyrus-sasl-gssapi
- depends = dbus-core
depends = ding-libs
- depends = krb5
- depends = ldb
- depends = libldap
depends = libnl
- depends = libsasl
depends = libunistring
- depends = libxml2
- depends = nspr
depends = nss
- depends = pcre
depends = smbclient
- depends = talloc
- depends = tdb
- depends = tevent
- provides = sssd=1.13.0.r69.gafa6ac7
+ depends = nfsidmap
+ depends = jansson
+ provides = sssd
conflicts = sssd
source = git+https://pagure.io/SSSD/sssd.git
- source = sssd.service
- sha1sums = SKIP
- sha1sums = 2d10db3d6f54a58bbf8d1f27328e68555256e0ce
+ sha512sums = SKIP
pkgname = sssd-git
diff --git a/PKGBUILD b/PKGBUILD
index e3b5fc6d0c68..48321dfe70ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,62 +1,61 @@
-# Maintainer: Mantas Mikulėnas <grawity@gmail.com>
+# Maintainer: Michael Lowman <michael.d.lowman@gmail.com>
+# Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+# Contributor: Mantas M. <grawity@gmail.com>
pkgname=sssd-git
-pkgver=1.13.0.r69.gafa6ac7
+_gitname='sssd'
+pkgver=2.2.3.r5.g58a67cd38
pkgrel=1
pkgdesc="System Security Services Daemon"
-arch=('i686' 'x86_64')
-url="https://fedorahosted.org/sssd/"
+arch=('x86_64')
+url="https://pagure.io/SSSD/sssd"
license=('GPL3')
depends=(
- 'augeas'
'bind' # for nsupdate
'c-ares'
'cyrus-sasl-gssapi'
- 'dbus-core'
'ding-libs'
- 'krb5'
- 'ldb'
- 'libldap'
'libnl'
- 'libsasl'
'libunistring'
- 'libxml2'
- 'nspr'
'nss'
- 'pcre'
'smbclient' # for libndr-nbt
- 'talloc'
- 'tdb'
- 'tevent'
+ 'nfsidmap'
+ 'jansson'
)
makedepends=(
'docbook-xsl'
'doxygen'
'python'
- 'python2'
'samba' # for libndr-nbt headers
+ 'systemd'
)
-provides=("sssd=$pkgver")
+provides=('sssd')
conflicts=('sssd')
-source=('git+https://pagure.io/SSSD/sssd.git'
- 'sssd.service')
-sha1sums=('SKIP'
- '2d10db3d6f54a58bbf8d1f27328e68555256e0ce')
+source=('git+https://pagure.io/SSSD/sssd.git')
+sha512sums=('SKIP')
pkgver() {
- cd "$srcdir/sssd"
- git describe | sed 's/^sssd-//; s/-/.r/; s/[_-]/./g'
+ cd "$_gitname"
+ git describe --tag | sed 's/^sssd-//;s/_/./g;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$srcdir/sssd"
- sed -i '1s/\<python\>/&2/' src/sbus/sbus_codegen
+ cd "$srcdir/$_gitname"
+ for f in "${source[@]}"; do
+ if [[ $f == *.patch ]]; then
+ msg2 "Applying $f"
+ patch -p1 < "$srcdir/$f"
+ fi
+ done
+
+ autoreconf -if
+
+ # dbus policy files in /usr/share/dbus-1
+ sed -i -e 's/^dbuspolicydir = $(sysconfdir)/dbuspolicydir = $(datadir)/' Makefile.in
}
build() {
- cd "$srcdir/sssd"
- export PYTHON=/usr/bin/python2
- autoreconf -i -f
+ cd "$srcdir/$_gitname"
./configure \
--prefix=/usr \
--sbindir=/usr/bin \
@@ -64,12 +63,10 @@ build() {
--localstatedir=/var \
--libexecdir=/usr/lib/sssd \
--datadir=/usr/share \
- --enable-all-experimental-features \
--enable-pammoddir=/usr/lib/security \
--with-initscript=systemd \
--with-os=fedora \
--with-pid-path=/run \
- --with-python2-bindings \
--with-python3-bindings \
--with-syslog=journald \
--without-selinux \
@@ -81,18 +78,17 @@ build() {
}
package() {
- cd "$srcdir/sssd"
- make DESTDIR="$pkgdir/" install
- rm -rf "$pkgdir/etc/rc.d"
- rm -rf "$pkgdir/lib"
- rm -rf "$pkgdir/run"
- rm -f "$pkgdir/usr/lib/ldb/modules/ldb/memberof.la"
- find "$pkgdir/usr" -depth -type d \
+ cd "$srcdir/$_gitname"
+ make -j1 DESTDIR="$pkgdir/" install
+ rm -rf "$pkgdir"/etc/rc.d
+ rm -rf "$pkgdir"/lib
+ rm -rf "$pkgdir"/run
+ rm -f "$pkgdir"/usr/lib/ldb/modules/ldb/memberof.la
+ find "$pkgdir"/usr -depth -type d \
-exec rmdir --ignore-fail-on-non-empty {} \;
cd "$srcdir"
rm -rf "$pkgdir/etc/systemd" # remove the drop-in
- install -Dm644 sssd.service "$pkgdir/usr/lib/systemd/system/sssd.service"
}
-# vim: ts=2:sw=2:et
+# vim: ts=2:sw=2:et:nowrap
diff --git a/sssd.service b/sssd.service
deleted file mode 100644
index c81dbc6d85be..000000000000
--- a/sssd.service
+++ /dev/null
@@ -1,12 +0,0 @@
-[Unit]
-Description=System Security Services Daemon
-Documentation=man:sssd(8)
-Before=rpc-idmapd.service
-
-[Service]
-ExecStart=/usr/bin/sssd -D -f
-Type=forking
-PIDFile=/run/sssd.pid
-
-[Install]
-WantedBy=multi-user.target